Please backport php-apcu 4.0.7-1build1 (universe) from vivid

Bug #1500167 reported by Sven Hoexter
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
trusty-backports
Undecided
Unassigned

Bug Description

Please backport php-apcu 4.0.7-1build1 (universe) from vivid to trusty.

Reason for the backport:
========================
Unfortunately the 4.0.2 release that got included into 14.04 is not a
good fit for a production enviroment. Beside of warnings that should
be debug statements there are deadlock conditions and even the upstream
author recommends against using this release.
Also current OwnCloud releases do not work with 4.0.2 which is quite
a popular thing to run on a Ubuntu LTS release these days.
Please read https://bugs.launchpad.net/ubuntu/+source/php-apcu/+bug/1374892
for the even longer version with references to issues caused by
php-apcu 4.0.7.

Testing:
========
* trusty:
[X] Package builds without modification
[X] php5-apcu installs cleanly and runs
[X] php-apc installs cleanly and runs (transitional package!)

I've added the package to my personal ppa, the version number is a bit
mangled because we had some back and forth at work.

Reverse dependencies:
=====================
php5-apcu
---------
* owncloud
  [ ] trusty (Reverse-Recommends)

php-apc
-------
* typo3-dummy
  [ ] trusty (Reverse-Recommends)
* tt-rss
  [ ] trusty (Reverse-Suggests)
* php5-common
  [ ] trusty (Reverse-Breaks)
* ldap-account-manager
  [ ] trusty (Reverse-Recommends)
* gosa
  [ ] trusty (Reverse-Suggests)
* typo3-src-4.5
  [ ] trusty (Reverse-Recommends)
* php5-xcache
  [ ] trusty (Reverse-Conflicts)

We did not check those specifically but we used it with the
stock Ubuntu 14.04 php stack.

Regards,
Sven

Revision history for this message
T. K. (stuttgart-live) wrote :

+1

Revision history for this message
Micah Gersten (micahg) wrote :

Thank you for your interest in Ubuntu Backports. I've uploaded this to trusty-backports based on the testing provided.

Changed in trusty-backports:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers