Please update haproxy trusty backport for USN-2668-1

Bug #1473162 reported by kloostec on 2015-07-09
264
This bug affects 2 people
Affects Status Importance Assigned to Milestone
trusty-backports
High
Unassigned

Bug Description

Please backport haproxy 1.5.4-1ubuntu2.1 (main) from utopic-updates to trusty.

Reason for the backport:
========================
http://www.ubuntu.com/usn/usn-2668-1/

Currently haproxy in trusty-backports is 1.5.3-1~ubuntu14.04.1 . We need one of the following versions backported:

1.5.4-1ubuntu2.1 from utopic
1.5.10-1ubuntu0.1 from vivid
1.5.14-1 from wily

Thanks!

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s utopic -d trusty haproxy

* trusty:
[X] Package builds without modification
[X] haproxy installs cleanly and runs
[X] haproxy-doc installs cleanly and runs
[X] vim-haproxy installs cleanly and runs
[X] haproxy-dbg installs cleanly and runs

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of haproxy. For reverse-build-dependencies (-Indep), please test that the package still builds against the new haproxy. For reverse-dependencies, please test that the version of the package currently in the release still works with the new haproxy installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

haproxy
-------
* neutron-lbaas-agent
  [ ] trusty (Reverse-Depends)

haproxy-doc
-----------

vim-haproxy
-----------

haproxy-dbgsym
--------------

haproxy-dbg
-----------

kloostec (kloostec) on 2015-07-09
information type: Private Security → Public Security
Micah Gersten (micahg) on 2015-07-10
description: updated
Micah Gersten (micahg) wrote :

I've gone ahead and uploaded test packages to my PPA (ppa:micahg/ppa). Would you mind doing the testing in the description and then I can go ahead and upload this to trusty-backports.

Micah Gersten (micahg) on 2015-07-10
Changed in trusty-backports:
importance: Undecided → High
kloostec (kloostec) wrote :

As we only have a prod environment for haproxy at the moment, I am quickly building a test environment that I can apply variants on my test environment to. I'll then do the testing requested in the bug plus also check that the functionality is working.

Micah Gersten (micahg) wrote :

That would be great, thank you!

kloostec (kloostec) wrote :

OK, I have installed the package from the ppa:micahg/ppa repository and it is performing as expected with a modified version of my configuration from production. I have tested TCP and HTTP load balancing, including HTTPS offloading (a new feature in the 1.5 series). I also tested the stats web interface. This is all of the haproxy functionality we typically use in our environment.

One issue I ran into when trying to install all of the packages listed in the description:

sudo apt-get install haproxy haproxy-doc vim-haproxy haproxy-dbgsym haproxy-dbg

E: Unable to locate package haproxy-dbgsym

I do not see this package listed at packages.ubuntu.com for trusty/utopic/vivid/wily, or on packages.debian.org for stable/testing/unstable.

I tried doing the build myself:

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s utopic -d trusty haproxy

but I do not have the correct GPG keys and such configured to do so, so I am hoping that your PPA version is sufficient for the build test.

Chris

Micah Gersten (micahg) wrote :

I think the dbgsym package in the list was a bug, I've removed it and marked off the packages that you tested, thanks! The one thing left is the reverse dependency ( neutron-lbaas-agent) which I'm going to see if I can test quickly.

description: updated
Micah Gersten (micahg) wrote :

I was not able to test neutron-lbaas-agent to insure that it still works, is there someone that can please do that?

kloostec (kloostec) wrote :

I installed neutron-lbaas-agent and it had no problems installing alongside the haproxy from the PPA repository. I also tried it on a clean installation without haproxy already installed and it pulled in the haproxy from the PPA and installed successfully. I can't do any functional tests as I have no experience with Openstack.

Chris

Micah Gersten (micahg) on 2015-08-23
Changed in trusty-backports:
status: New → In Progress
assignee: nobody → Micah Gersten (micahg)
Micah Gersten (micahg) wrote :

Uploaded to trusty-backports and accepted based on provided feedback, thanks

Changed in trusty-backports:
assignee: Micah Gersten (micahg) → nobody
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Duplicates of this bug

Other bug subscribers