Please backport swig 3.0.2-1ubuntu1 (universe) from utopic

Bug #1448823 reported by Thomas Ward
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
trusty-backports
Undecided
Unassigned

Bug Description

Please backport swig 3.0.2-1ubuntu1 (universe) from utopic to trusty.

Reason for the backport:
========================
Prerequisite for Bug #1444943 against ZNC (https://bugs.launchpad.net/ubuntu/+source/znc/+bug/1444943) and a prerequisite for any ZNC 1.6+ backports (with the current packaging and requirements) to ever be done.

The swig3.0 libraries are required for more recent versions of ZNC. ZNC 1.6 has a build-dep on swig3.0, and as swig3.0 is not in Trusty it should be backported.

Test builds will be available in https://launchpad.net/~teward/+archive/ubuntu/backport-buildtests. Note that I already have swig3.0 backports available in https://launchpad.net/~teward/+archive/ubuntu/swig3.0 (which do NOT follow the typical PPA versioning scheme as the idea is that PPA will always supersede what's in Ubuntu Backports as ZNC needs newer libraries) and there are no fail to build errors on Trusty, or even Precise. The backported version in my swig3.0 PPA is actively used in build tests on every single commit to the ZNC github repository (on Travis-CI) and the package operates as expected. I also use the backported version in that swig3.0 PPA of mine as part of the build-deps for the ZNC Stable PPAs I maintain, and they operate well and work.

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s utopic -d trusty swig

* trusty:
[X] Package builds without modification
[X] swig3.0 installs cleanly - Runtime Test Not Applicable: swig3.0 is an interface that generates scripting interfaces to C/C++ code. Testing would require building with swig3.0 available for a given application that is not swig3.0.
[X] swig3.0-doc installs cleanly - Runtime Test Not Applicable: This is the HTML documentation and is not an executable.
[X] swig3.0-examples installs cleanly - Runtime Test Not Applicable: This is just examples of applications for SWIG and is not an executable.

No reverse dependencies

Revision history for this message
Thomas Ward (teward) wrote :

NOTE: None of these binaries is actually executable. These are mostly interpreter libraries called during compiling and building by other functions in order to generate scripting interfaces to C/C++. This is a build-dep for ZNC 1.6, which is a different bug. There was a backport request for ZNC 1.6 from Vivid to Trusty in https://bugs.launchpad.net/ubuntu/+source/znc/+bug/1444943 however this backport request is still necessary as a prerequisite before I go doing backport tests for the ZNC package or before requesting such backports.

description: updated
Thomas Ward (teward)
description: updated
description: updated
Revision history for this message
Micah Gersten (micahg) wrote :

The "run" test would suffice by trying to compile something like ZNC against swig 3.0, could you please verify that ZNC actually builds against the new swig (and the relevant tests pass).

Changed in trusty-backports:
assignee: nobody → Thomas Ward (teward)
status: New → Incomplete
Revision history for this message
Thomas Ward (teward) wrote :

PPA build tests of ZNC have been done in https://launchpad.net/~teward/+archive/ubuntu/backport-buildtests with the swig3.0 package in the PPA (which is the build-test of this backport request). The ZNC package from Vivid (no-changes and targeting Trusty) have built with swig3.0.

Note that the Trusty targeted ZNC package in that backport build tests PPA is for the backport request for ZNC (https://bugs.launchpad.net/trusty-backports/+bug/1449248 is the backport request for ZNC. #1444943 is now marked as a duplicate of that bug.)

description: updated
Changed in trusty-backports:
assignee: Thomas Ward (teward) → nobody
status: Incomplete → New
Revision history for this message
Micah Gersten (micahg) wrote :

Uploaded

Changed in trusty-backports:
status: New → Fix Committed
Revision history for this message
Micah Gersten (micahg) wrote :

Accepted and building now

Changed in trusty-backports:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers