Please backport yelp-xsl 3.12.0-1 (main) from utopic

Bug #1411094 reported by Doug Smythies on 2015-01-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
trusty-backports
Undecided
Unassigned

Bug Description

Please backport yelp-xsl 3.12.0-1 (main) from utopic to trusty.

Reason for the backport:
========================
For many many months prior to the initial release of 14.04 (Trusty) we, the Ubuntu Doc Team, had been working on issues with the official documentation and the related higher level tools. Some solutions and workarounds had been able to be implemented in the documentation, other fixes required changes to yelp-xsl (and yelp-tools). In some cases the solutions are interdependent, meaning changes to the documentation requires the newer version of the tools and style sheets to result in the correct rendering for display or compiling into html.

A bug report was submitted requesting that Ubuntu release 14.04 have at least yelp-xsl version 3.11.5. That never happened.
O.K. so now we are requesting a backport, as server type people tend to stay with LTS releases we need to be able to have people build the documents on 14.04 servers.

References:
https://bugs.launchpad.net/ubuntu/+source/yelp-tools/+bug/1276230
https://bugs.launchpad.net/ubuntu/+source/yelp-xsl/+bug/1276227

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

Test build kindly provided by Gunnar Hjalmarsson and available at:
https://launchpad.net/~ubuntu-core-doc/+archive/ubuntu/ppa

* trusty:
[X] Package builds without modification
[X] yelp-xsl installs cleanly and runs on Ubuntu server
[X] yelp-xsl installs cleanly and runs on Ubuntu desktop
[X] yelp-xsl installs cleanly and runs on Ubuntu desktop, with GNOME, GNOME flashback (Compiz), GNOME Flashback (Metacity), Ubuntu (default)

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of yelp-xsl. For reverse-build-dependencies (-Indep), please test that the package still builds against the new yelp-xsl. For reverse-dependencies, please test that the version of the package currently in the release still works with the new yelp-xsl installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

yelp-xsl
--------
* gnome-core-devel
  [X] trusty (Reverse-Depends)
* yelp-tools
  [X] trusty (Reverse-Build-Depends)
  This is a linked backport request, with yelp-tools
* ubuntu-gnome-desktop
  [X] trusty (Reverse-Depends)
* yelp
  [X] trusty (Reverse-Depends)
  [X] trusty (Reverse-Build-Depends)
* libgda5
  [X] trusty (Reverse-Build-Depends)

Note 1: I tested building the serverguide and desktop help, and examined every difference. There are additional .css file entries, as things evolved since my builds of the tools directly from git://git.gnome.org/yelp-xsl a year ago. We do not use the added .css file entries (we didn't even know about them)

Note 2: There are probably other use cases for these tools, but I wouldn't know what they are or how to test them.

description: updated
description: updated
Doug Smythies (dsmythies) wrote :

Apparently it is up to me to do the testing such that each check box is dealt with.

There isn't a package called "libgda5", so what to do for that line seems unclear. There are many packages listed if the search term is shortened to "libgda", but even then it remains unclear what is the correct one.

O.K. so trying "yelp" instead. Using these references:
https://help.ubuntu.com/community/CompilingSoftware
https://help.ubuntu.com/community/CompilingEasyHowTo
doesn't seem to work, so try just getting the bzr branch instead.

Oddly (or perhaps not, why would anything be consistent), while I'm used to (for example):
bzr push lp:serverguide/precise
it seems the order is different for yelp:
bzr branch lp:ubuntu/trusty/yelp
which I find bizarre (pun intended).

However, then autogen.sh complains that I don't have a package called gtk-doc. O.K. simple enough, however, there isn't a package called gtk-doc. O.K. I'm not sure how, but I guess I am expected to figure out that it really means gtk-doc-tools.

And now autogen.sh complains about:
configure.ac:24: error: possibly undefined macro: AM_PATH_GLIB_2_0
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1

And I give up.

Doug Smythies (dsmythies) wrote :

Somewhere I read that I could do this:

apt-get install source yelp

and then do this:

dpkg-buildpackage

So I tried it. Important note: I didn't change yelp-xsl or yelp-tools yet, they are the standard trusty versions, as I am just trying to establish that things work properly BEFORE backporting them.

Once I install all the missing packages it complains about, it builds.

O.K. so moving on, update yelp-xsl and yelp-tools as per these two backport requests.

The build fails:

dpkg-source: info: you can integrate the local changes with dpkg-source --commit
dpkg-source: error: aborting due to unexpected upstream changes, see /tmp/yelp_3.10.2-0ubuntu1.diff.IO4pEb
dpkg-buildpackage: error: dpkg-source -b yelp-3.10.2 gave error exit status 2

However, this works:

./autogen.sh
make

So I don't really know if this is a pass or a fail.

Gunnar Hjalmarsson (gunnarhj) wrote :

Doug,

I don't understand the meaning of the build fail you show in comment #2.

For me yelp starts and runs fine with this combination:

$ dpkg-query -W yelp-xsl yelp
yelp 3.10.2-0ubuntu1
yelp-xsl 3.12.0-1~trusty~ppa

As regards building, I could successfully run this series of commands:

mkdir testbuild
cd testbuild
apt-get source yelp
cd yelp-3.10.2
debuild -uc -us

So I'd say it's a pass. Marked it as such.

description: updated
Doug Smythies (dsmythies) wrote :

Gunnar,

Thanks so much. Your build method works for me also, but only on a fresh "apt-get source yelp".
I'll continue using your method.

description: updated
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2015-01-20 19:47, Doug Smythies wrote:
> * gnome-core-devel
> [ ] trusty (Reverse-Depends)
> + I do not know how to test this one.

Just a meta package, depending on yelp-xsl (>= 3.4). Nothing to test, really.

> * libgda5
> [ ] trusty (Reverse-Build-Depends)
> + Not Applicable, no such package.

Yes, there is such a (source) package.
https://launchpad.net/ubuntu/+source/libgda5

description: updated
description: updated
Changed in trusty-backports:
status: New → Confirmed
Felix Geyer (debfx) wrote :

Accepted into trusty-backports.

Changed in trusty-backports:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers