Please backport wxwidgets3.0 3.0.1-1ubuntu1 (universe) from utopic

Bug #1333428 reported by Gianfranco Costamagna
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
trusty-backports
Undecided
Unassigned
wxwidgets3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Please backport wxwidgets3.0 3.0.1-1ubuntu1 (universe) from utopic to trusty.

Reason for the backport:
========================
I would like to have it in order to backport the new boinc (with webview support)

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s utopic -d trusty wxwidgets3.0

* trusty:
[x] Package builds without modification
[x] libwxgtk3.0-0 installs cleanly and runs
[x] libwxgtk-webview3.0-0 installs cleanly and runs
[x] wx-common installs cleanly and runs
[x] libwxgtk-media3.0-0-dbg installs cleanly and runs
[x] libwxbase3.0-0-dbg installs cleanly and runs
[x] libwxgtk-media3.0-0 installs cleanly and runs
[x] libwxgtk-media3.0-dev installs cleanly and runs
[x] wx3.0-examples installs cleanly and runs
[x] libwxbase3.0-dev installs cleanly and runs
[x] wx3.0-i18n installs cleanly and runs
[x] libwxgtk3.0-dev installs cleanly and runs
[x] libwxgtk-webview3.0-dev installs cleanly and runs
[x] libwxgtk-webview3.0-0-dbg installs cleanly and runs
[x] wx3.0-headers installs cleanly and runs
[x] libwxbase3.0-0 installs cleanly and runs
[x] libwxgtk3.0-0-dbg installs cleanly and runs

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of wxwidgets3.0. For reverse-build-dependencies (-Indep), please test that the package still builds against the new wxwidgets3.0. For reverse-dependencies, please test that the version of the package currently in the release still works with the new wxwidgets3.0 installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

libwxgtk3.0-0
-------------
* golly
  [ ] trusty (Reverse-Depends)
* sffview
  [ ] trusty (Reverse-Depends)
* wxmaxima
  [ ] trusty (Reverse-Depends)
* saga
  [ ] trusty (Reverse-Depends)
* fityk
  [ ] trusty (Reverse-Depends)
* libsaga
  [ ] trusty (Reverse-Depends)
* mkvtoolnix-gui
  [ ] trusty (Reverse-Depends)
* 0ad
  [ ] trusty (Reverse-Depends)
* aegisub
  [ ] trusty (Reverse-Depends)
* rapidsvn
  [ ] trusty (Reverse-Depends)

libwxgtk-webview3.0-0
---------------------

wx-common
---------
* spatialite-gui
  [ ] trusty (Reverse-Build-Depends)
* codeblocks
  [ ] trusty (Reverse-Suggests)
  [ ] trusty (Reverse-Build-Depends)
* nautic
  [ ] trusty (Reverse-Build-Depends)
* saga
  [ ] trusty (Reverse-Build-Depends)
* barry
  [ ] trusty (Reverse-Build-Depends)
* filezilla
  [ ] trusty (Reverse-Build-Depends)
* wxhexeditor
  [ ] trusty (Reverse-Build-Depends)
* libwxgtk-media2.8-dev
  [ ] trusty (Reverse-Depends)
* libwxgtk2.8-dev
  [ ] trusty (Reverse-Depends)
* pyhoca-gui
  [ ] trusty (Reverse-Depends)
* xaralx
  [ ] trusty (Reverse-Build-Depends)
* usbprog
  [ ] trusty (Reverse-Build-Depends)
* codelite
  [ ] trusty (Reverse-Recommends)
* spek
  [ ] trusty (Reverse-Build-Depends)
* poedit
  [ ] trusty (Reverse-Build-Depends)

libwxgtk-media3.0-0-dbg
-----------------------

libwxbase3.0-0-dbg
------------------

libwxgtk-media3.0-0
-------------------

libwxgtk-media3.0-dev
---------------------

wx3.0-examples
--------------

libwxbase3.0-0
--------------
* golly
  [ ] trusty (Reverse-Depends)
* sffview
  [ ] trusty (Reverse-Depends)
* wxmaxima
  [ ] trusty (Reverse-Depends)
* saga
  [ ] trusty (Reverse-Depends)
* fityk
  [ ] trusty (Reverse-Depends)
* libsaga
  [ ] trusty (Reverse-Depends)
* mkvtoolnix-gui
  [ ] trusty (Reverse-Depends)
* 0ad
  [ ] trusty (Reverse-Depends)
* aegisub
  [ ] trusty (Reverse-Depends)
* rapidsvn
  [ ] trusty (Reverse-Depends)

libwxbase3.0-dev
----------------

wx3.0-i18n
----------

libwxgtk3.0-dev
---------------
* golly
  [ ] trusty (Reverse-Build-Depends)
* sffview
  [ ] trusty (Reverse-Build-Depends)
* wxmaxima
  [ ] trusty (Reverse-Build-Depends)
* saga
  [ ] trusty (Reverse-Build-Depends)
* mkvtoolnix
  [ ] trusty (Reverse-Build-Depends)
* fityk
  [ ] trusty (Reverse-Build-Depends)
* 0ad
  [ ] trusty (Reverse-Build-Depends)
* aegisub
  [ ] trusty (Reverse-Build-Depends)
* rapidsvn
  [ ] trusty (Reverse-Build-Depends)

libwxgtk-webview3.0-dev
-----------------------

libwxgtk-webview3.0-0-dbg
-------------------------

wx3.0-headers
-------------

libwxgtk3.0-0-dbg
-----------------

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Everything still builds on my ppa
https://launchpad.net/~costamagnagianfranco/+archive/firefox/+packages

and I'm testing some of them right now on my machine.

Is that enough? We are going to backport wx in debian too

Revision history for this message
Felix Geyer (debfx) wrote :

Have you tested at least some of the reverse dependencies?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I'm testing boinc right now, anyway I don't think there is real need to test reverse-deps, since this backbort is API/ABI compatible, and it adds just a new package.
(debian accepted the backbort a couple of days ago)

how do you suggest to test? just rebuild and run?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

tested fityk boinc aegisub wxmaxima successfully tested.

Revision history for this message
Felix Geyer (debfx) wrote :

Install some of the applications (no rebuild) and do some basic testing to make sure they still work.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

yes, I have the backport installed since I built it (even before, I built it locally since it was requested for boinc)

I tested fityk boinc aegisub wxmaxima filezilla with success. (maybe more apps, in 15 days so much has been opened/closed in my computer :))

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Dear Paul Müller, please open a new bug if you want wxpython3.0 backported too (requestbackport command helps you)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Revision history for this message
Olly Betts (ojwb) wrote :

Reassigning to the correct package

affects: wxpython3.0 (Ubuntu) → wxwidgets3.0 (Ubuntu)
Changed in wxwidgets3.0 (Ubuntu):
status: New → Confirmed
Changed in wxwidgets3.0 (Ubuntu):
status: New → Invalid
Changed in trusty-backports:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers