MongoDB guest won't start

Bug #1446735 reported by Doug Shelley on 2015-04-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack DBaaS (Trove)
High
Doug Shelley
Kilo
High
Unassigned

Bug Description

Testing MongoDB guest on Ubuntu Trusty.

Using MongoDB 2.4, I get this:
Tue Apr 21 14:53:21.940 [signalProcessingThread] got signal 15 (Terminated), will terminate after current cmd ends

Also noticed this in /var/log/syslog:
Apr 21 14:53:26 mongo-instance kernel: [ 35.413444] init: mongodb main process (1362) terminated with status 1

On further analysis, I noticed that /etc/mongodb.conf contained this:
[Service]
# (file size)
LimitFSIZE=infinity
# (cpu time)
LimitCPU=infinity
# (virtual memory size)
LimitAS=infinity
# (open files)
LimitNOFILE=64000
# (processes/threads)
LimitNPROC=64000

This stanza is totally invalid for Mongo. I believe it was supposed to be written to a Mongo systemd start script not to /etc/mongodb.conf.

For reference the change that caused this is https://review.openstack.org/#/c/150131.

At this point, the Mongo guest will not start on any platform and has been broken since this change merged on Jan 30th.

Doug Shelley (0-doug) on 2015-04-21
Changed in trove:
assignee: nobody → Doug Shelley (0-doug)
Amrith Kumar (amrith) on 2015-04-21
Changed in trove:
status: New → Confirmed
importance: Undecided → High
tags: added: kilo-rc-potential
Changed in trove:
milestone: none → ongoing

Fix proposed to branch: master
Review: https://review.openstack.org/176067

Changed in trove:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/176067
Committed: https://git.openstack.org/cgit/openstack/trove/commit/?id=31fe90a6a899cab4751b1947823ef138869c1fe5
Submitter: Jenkins
Branch: master

commit 31fe90a6a899cab4751b1947823ef138869c1fe5
Author: Doug Shelley <email address hidden>
Date: Tue Apr 21 16:37:56 2015 -0400

    Remove [Service] section from mongo config tmpl

    The mongodb guest wasn't starting up on Ubuntu or Fedora
    due to the presense of a [Service] section in /etc/mongodb.conf.
    I believe this section was not intended for config.template but
    should be in the systemd script for mongo. For now, we will
    revert this change and consider a better way to fix it for
    Liberty.

    The change that introduced this is:
    https://review.openstack.org/#/c/150131

    Change-Id: I090c95185f732485a21f6d38df1655e205a07224
    Closes-bug: 1446735

Changed in trove:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2015-04-22
tags: removed: kilo-rc-potential

Reviewed: https://review.openstack.org/176223
Committed: https://git.openstack.org/cgit/openstack/trove/commit/?id=4a9c718a285f64c8baddeab3c88fa1c1bb5d3322
Submitter: Jenkins
Branch: stable/kilo

commit 4a9c718a285f64c8baddeab3c88fa1c1bb5d3322
Author: Doug Shelley <email address hidden>
Date: Tue Apr 21 16:37:56 2015 -0400

    Remove [Service] section from mongo config tmpl

    The mongodb guest wasn't starting up on Ubuntu or Fedora
    due to the presense of a [Service] section in /etc/mongodb.conf.
    I believe this section was not intended for config.template but
    should be in the systemd script for mongo. For now, we will
    revert this change and consider a better way to fix it for
    Liberty.

    The change that introduced this is:
    https://review.openstack.org/#/c/150131

    Cherry-pick of 31fe90a6a899cab4751b1947823ef138869c1fe5 from master
    Change-Id: I090c95185f732485a21f6d38df1655e205a07224
    Closes-bug: 1446735

Reviewed: https://review.openstack.org/179292
Committed: https://git.openstack.org/cgit/openstack/trove/commit/?id=818af811292816172072a8995ccf569a19af3643
Submitter: Jenkins
Branch: master

commit 4a9c718a285f64c8baddeab3c88fa1c1bb5d3322
Author: Doug Shelley <email address hidden>
Date: Tue Apr 21 16:37:56 2015 -0400

    Remove [Service] section from mongo config tmpl

    The mongodb guest wasn't starting up on Ubuntu or Fedora
    due to the presense of a [Service] section in /etc/mongodb.conf.
    I believe this section was not intended for config.template but
    should be in the systemd script for mongo. For now, we will
    revert this change and consider a better way to fix it for
    Liberty.

    The change that introduced this is:
    https://review.openstack.org/#/c/150131

    Cherry-pick of 31fe90a6a899cab4751b1947823ef138869c1fe5 from master
    Change-Id: I090c95185f732485a21f6d38df1655e205a07224
    Closes-bug: 1446735

commit 9133969d21e6952aecae88593d7668dc56c6f15c
Author: Andreas Jaeger <email address hidden>
Date: Mon Apr 20 12:06:55 2015 +0200

    Release Import of Translations from Transifex

    Manual import of Translations from Transifex. This change also removes
    all po files that are less than 66 per cent translated since such
    partially translated files will not help users.

    This updates also recreates all pot (translation source files) to
    reflect the state of the repository.

    This change needs to be done manually since the automatic import does
    not handle the proposed branches and we need to sync with latest
    translations.

    Change-Id: Ib8f04f3522cbd6c652db7de75d8695211cddc09b

commit 9ea915cda70b685c2d9d09bd92eefe44e1558ee7
Author: Thierry Carrez <email address hidden>
Date: Fri Apr 17 10:34:09 2015 +0200

    update .gitreview for stable/kilo

    Change-Id: I5b1e84debb19b491f7e0569fe078d80e93a8a154

commit f258d3eb9b7e7362b7de0f5c1dcf318e9085bd10
Author: OpenStack Proposal Bot <email address hidden>
Date: Thu Apr 16 12:13:32 2015 +0000

    Updated from global requirements

    Change-Id: I0ef6b9bf84eebe802ff0aece3f3c01e5d9ecb32c

Changed in trove:
status: Fix Committed → Fix Released

This issue was fixed in the openstack/trove 2015.1.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers