pid_file is not editable in the configuration group

Bug #1344094 reported by Ionuț Arțăriși on 2014-07-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack DBaaS (Trove)
Wishlist
Nikhil Manchanda

Bug Description

I'm trying to create a configuration with a custom pid_file location, but I get the following error:

$ trove configuration-create pidfile '{"pid_file" : "/var/lib/mysql/mysqld.pid"}' --datastore 6c69c477-7ad0-4322-a151-e2f98c4b2b0f
ERROR: pid_file is not a supported configuration parameter. (HTTP 422)

Denis M. (dmakogon) wrote :

You have to extend a list of validation rules at validation_rules.json at trove/templates/mysql/

Changed in trove:
status: New → Invalid
Amrith Kumar (amrith) wrote :

Why is this invalid? Ionut do you agree?

Ionuț Arțăriși (mapleoin) wrote :

@Denis, if that is indeed how to get this configuration value changed and it requires changing the validation_rules.json file, then that file should be in /etc/, not in /usr/lib

So the way I see it, there are two things to change here: the location of validation_rules.json and documentation.

Changed in trove:
status: Invalid → New
Denis M. (dmakogon) wrote :

Ionut, of course. This is how can it be done. If you can recall we've discussed this case long time ago. And i suggest to add specific validation rule to validation_rules.json

After that there were no activity around this question.

@Amrith. This is not a bug because Trove was made in that way in which you could use custom validation_rules.json without touching codebase, same for config templates, heat templates, etc.

Just as an example. Amrith, if you still think that this is a bug then we should enter certain set of bugs for each missing configuration option for MySQL datastore.

Changed in trove:
status: New → Triaged
importance: Undecided → Wishlist
assignee: nobody → Nikhil Manchanda (slicknik)
milestone: none → ongoing
Amrith Kumar (amrith) wrote :

Nikhil, any updates on this?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers