no package kvm-ipxe on Ubuntu16.04

Bug #1695686 reported by BillXiang on 2017-06-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Trove Integration
Undecided
Unassigned

Bug Description

When I use trove-integration on master to install trove on Ubuntu16.04, it has a error.
The error log is as follows:

*******************************************************************************
Updating dependencies (part 1a)...
*******************************************************************************
Updating ...
Hit:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease
Get:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Ign:4 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-updates/ocata InRelease
Get:5 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-updates/ocata Release [7,882 B]
Get:6 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-updates/ocata Release.gpg [543 B]
Get:7 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Get:8 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [276 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [544 kB]
Get:10 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-updates/ocata/main amd64 Packages [146 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [528 kB]
Get:12 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [263 kB]
Get:13 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [118 kB]
Get:14 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages [7,420 B]
Get:15 http://security.ubuntu.com/ubuntu xenial-security/restricted i386 Packages [7,420 B]
Get:16 http://security.ubuntu.com/ubuntu xenial-security/restricted Translation-en [2,428 B]
Get:17 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [125 kB]
Get:18 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [112 kB]
Get:19 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en [64.7 kB]
Get:20 http://us.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [220 kB]
Get:21 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages [7,772 B]
Get:22 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted i386 Packages [7,772 B]
Get:23 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted Translation-en [2,548 B]
Get:24 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [471 kB]
Get:25 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [456 kB]
Get:26 http://ubuntu-cloud.archive.canonical.com/ubuntu xenial-updates/ocata/main i386 Packages [146 kB]
Get:27 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [185 kB]
Get:28 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse i386 Packages [7,996 B]
Get:29 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse Translation-en [4,460 B]
Get:30 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 Packages [5,624 B]
Get:31 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe i386 Packages [5,620 B]
Get:32 http://us.archive.ubuntu.com/ubuntu xenial-backports/universe Translation-en [2,872 B]
Fetched 4,031 kB in 5s (794 kB/s)
Reading package lists... Done
*******************************************************************************
Installing dependencies (part 1b)...
*******************************************************************************
Installing python-pip...
Reading package lists... Done
Building dependency tree
Reading state information... Done
python-pip is already the newest version (8.1.1-2ubuntu0.4).
0 upgraded, 0 newly installed, 0 to remove and 110 not upgraded.
Installing git-core kvm-ipxe gettext...
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package kvm-ipxe

BillXiang (xiangbinbin) on 2017-06-04
description: updated
Valencia Edna Serrao (vserrao) wrote :

Hi!
I too faced the same issue. I found that 'kvm-ipxe' is not available on Ubuntu16.04 (https://packages.ubuntu.com/xenial/). I then used 'ipxe-qemu' instead (https://packages.ubuntu.com/trusty/kvm-ipxe). With that, my setup progressed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers