Users page show error with Allowed Host and Databases

Bug #1737695 reported by Yao Wang on 2017-12-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
trove-dashboard
Undecided
Yao Wang

Bug Description

I found Users page can't show correct information of the same user_name with different Allowed Hosts and dbs.
Here is an example, the cmd user-list show result as:
 trove user-list bbbb
+-----------+--------------+-----------+
| Name | Host | Databases |
+-----------+--------------+-----------+
| testuser | % | db1 |
| testuser | 10.128.2.1 | |
| testuser | 10.254.5.106 | |
| testuser1 | % | db2 |
| testuser1 | 10.254.2.108 | |
+-----------+--------------+-----------+

But the dashboard Users page show info as:

User Name Allowed Host Databases
testuser1 % db2
testuser1 % db2
testuser % db1
testuser % db1
testuser % db1

The user_name with different Allowed Hosts or dbs show the same result. Obviously,this is not correct.

Yao Wang (nihaome521) on 2017-12-12
Changed in trove-dashboard:
assignee: nobody → Yao Wang (nihaome521)

Fix proposed to branch: master
Review: https://review.openstack.org/527629

Changed in trove-dashboard:
status: New → In Progress

Reviewed: https://review.openstack.org/527629
Committed: https://git.openstack.org/cgit/openstack/trove-dashboard/commit/?id=ac30be57ae4c02bcd122af28f3d0d73eafe34ac6
Submitter: Zuul
Branch: master

commit ac30be57ae4c02bcd122af28f3d0d73eafe34ac6
Author: wangyao <email address hidden>
Date: Wed Dec 13 16:28:27 2017 +0800

    Fix users page display error

    According bug description, the users page show error
    with host and dbs. The cause of the problem is we can
    not only use user_name as id, it is not unique. Now I
    changed the id as the combination of user_name and
    user_host.

    Change-Id: I28136de2b7c79633dd51bdea5d704038c29aa516
    Closes-Bug: #1737695

Changed in trove-dashboard:
status: In Progress → Fix Released

This issue was fixed in the openstack/trove-dashboard 10.0.0.0b3 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers