Scenario 001 master failing with ERROR! Could not find specified file in role: tasks/tripleo_podman_service

Bug #1997664 reported by Sandeep Yadav
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Fix Released
Critical
Takashi Kajinami

Bug Description

Description:

Scenario 001 master failing with ERROR! Could not find specified file in role: tasks/tripleo_podman_service

Issue started on 24th Nov:

https://zuul.opendev.org/t/openstack/builds?job_name=tripleo-ci-centos-9-scenario001-standalone&project=openstack/puppet-tripleo

Error snippet:

https://storage.bhs.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_b99/846537/4/gate/tripleo-ci-centos-9-scenario001-standalone/b9961a4/logs/undercloud/home/zuul/standalone_deploy.log

~~~
2022-11-24 05:14:57.246756 | fa163e7f-83e9-ff5c-716a-00000000095d | TIMING | create podman socket for sensubility purposes | standalone | 0:01:55.379980 | 0.04s
ERROR! Could not find specified file in role: tasks/tripleo_podman_service
 [ERROR]: An include failure occurred, we will not continue to process after
this play completes.
~~~

Changed in tripleo:
assignee: nobody → Takashi Kajinami (kajinamit)
Changed in tripleo:
status: Triaged → In Progress
Revision history for this message
Takashi Kajinami (kajinamit) wrote :

This is the regression caused by https://review.opendev.org/c/openstack/tripleo-ansible/+/865047 .

We recently renamed the task files in tripleo-podman role, following the general guideline of standalone roles but did not add the link for some task files used by collectd.

The following fix has been proposed to master and this should add the missing links as a short-term solution.
 https://review.opendev.org/c/openstack/tripleo-ansible/+/865503

Revision history for this message
Takashi Kajinami (kajinamit) wrote :

Submitted a tripleo-ci patch so that we can catch a similar regression in the future.
 https://review.opendev.org/c/openstack/tripleo-ci/+/865506

tags: added: ci
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-ansible (master)

Reviewed: https://review.opendev.org/c/openstack/tripleo-ansible/+/865503
Committed: https://opendev.org/openstack/tripleo-ansible/commit/a0dc6efe88a24eebfe7d2a2499b35fd64cae20e7
Submitter: "Zuul (22348)"
Branch: master

commit a0dc6efe88a24eebfe7d2a2499b35fd64cae20e7
Author: Takashi Kajinami <email address hidden>
Date: Thu Nov 24 15:40:48 2022 +0900

    Fix missing links for old names

    We have renamed the task files for tripleo_podman_role[1] but we missed
    adding link for the following files though these are still used by
    the collectd service template.
     - tripleo_service.yml
     - tripleo_rsyslog_cleanup.yml

    This change adds the links to unblock CI now. All symbolic links will
    be removed later once references in tht are updated to use the new
    names.

    [1] 0692c49525c3a5a4680ff0b9e15bbfe2822639a3

    Closes-Bug: #1997664
    Change-Id: I0646f49a6572b800b87a01f904833c689dc8759b

Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers