openstack-tox-py36 is failing on tripleo-heat-templates master tests - oslo-log

Bug #1974244 reported by Ronelle Landy
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Fix Released
Critical
Unassigned

Bug Description

openstack-tox-py36 is failing on tripleo-heat-templates master tests with the following error:

2022-05-19 19:22:47.570780 | ubuntu-bionic | ERROR: Cannot install -r /home/zuul/src/opendev.org/openstack/tripleo-heat-templates/requirements.txt (line 7) because these package versions have conflicting dependencies.
2022-05-19 19:22:47.570889 | ubuntu-bionic |
2022-05-19 19:22:47.570925 | ubuntu-bionic | The conflict is caused by:
2022-05-19 19:22:47.570952 | ubuntu-bionic | tripleo-common 16.4.0 depends on oslo.log>=3.36.0
2022-05-19 19:22:47.570977 | ubuntu-bionic | The user requested (constraint) oslo-log===5.0.0
2022-05-19 19:22:47.571013 | ubuntu-bionic |
2022-05-19 19:22:47.571033 | ubuntu-bionic | To fix this you could try to:
2022-05-19 19:22:47.571053 | ubuntu-bionic | 1. loosen the range of package versions you've specified
2022-05-19 19:22:47.571073 | ubuntu-bionic | 2. remove package versions to allow pip attempt to solve the dependency conflict
2022-05-19 19:22:47.571094 | ubuntu-bionic |
2022-05-19 19:22:47.571123 | ubuntu-bionic | ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependencies
2022-05-19 19:22:47.865862 | ubuntu-bionic | ERROR: invocation failed (exit code 1)

The test history is included below:

https://zuul.openstack.org/builds?job_name=openstack-tox-py36&project=openstack%2Ftripleo-heat-templates&skip=0

Revision history for this message
Ronelle Landy (rlandy) wrote :
Changed in tripleo:
milestone: none → zed-1
importance: Undecided → Critical
status: New → Triaged
tags: added: promotion-blocker
Revision history for this message
Ronelle Landy (rlandy) wrote :
Revision history for this message
Ronelle Landy (rlandy) wrote :

https://pypi.org/project/oslo.log/ - released 12 hours ago

Revision history for this message
Marios Andreou (marios-b) wrote :

we tried changing the tripleo-common requirement to match the upperconstraints with https://review.opendev.org/c/openstack/tripleo-common/+/842672 but same result

the error doesn't even make sense like:

    tripleo-common 16.4.0 depends on oslo.log>=3.36.0
    The user requested (constraint) oslo-log===5.0.0

so? what is the problem? install 5.0.0 where is the conflict

suspected issue with pypi cache from opendev? chkumar tried and hit a similar issue:

 10:09 < chandankumar> marios: on using opendev indexes , I am hitting this
                      https://paste.centos.org/view/raw/accad93c

Revision history for this message
chandan kumar (chkumar246) wrote :

content from https://paste.centos.org/view/raw/accad93c
tripleo-heat-templates on  bug/1974244 [$?] via ? v3.10.4 (oslo_log_repr) took 33s
❯ pip install -i https://mirror.gra1.ovh.opendev.org/pypi/simple,https://mirror.gra1.ovh.opendev.org/wheel/ubuntu-18.04-x86_64 -c https://opendev.org/openstack/requirements/raw/branch/master/upper-constraints.txt -r requirements.txt -r test-requirements.txt
Looking in indexes: https://mirror.gra1.ovh.opendev.org/pypi/simple,https://mirror.gra1.ovh.opendev.org/wheel/ubuntu-18.04-x86_64
ERROR: Cannot install pbr!=2.1.0 and >=2.0.0 because these package versions have conflicting dependencies.

The conflict is caused by:
    The user requested pbr!=2.1.0 and >=2.0.0
    The user requested (constraint) pbr===5.9.0

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/topics/dependency-resolution/#dealing-with-dependency-conflicts

Revision history for this message
Marios Andreou (marios-b) wrote :

thanks tkajinam we can instead try bumping the python jobs template to the zed version

py36 comes from [1]. Since this is master we can try switching to the zed template that doesn't have the py36 jobs [2].

We confirmed the issue seems limited to master (testing wallaby with [3]) so the patch from takashi at [4] is OK lets go with that

[1] https://opendev.org/openstack/openstack-zuul-jobs/src/commit/584d63be0c95c17dd1577320f981d9293454609b/zuul.d/project-templates.yaml#L689

[2] https://opendev.org/openstack/openstack-zuul-jobs/src/commit/584d63be0c95c17dd1577320f981d9293454609b/zuul.d/project-templates.yaml#L542

[3] https://zuul.opendev.org/t/openstack/build/5e050df3abbc4ae5a95d76f567f9e8a1

[4] https://review.opendev.org/c/openstack/tripleo-heat-templates/+/842675/

Revision history for this message
Ian Wienand (iwienand) wrote :

So to the original error, the oslo.log release dropped Python 3.6 support, which is why this is saying it can't install 5.0.0 now

https://opendev.org/openstack/oslo.log/commit/cdbf6e7a915059df7820b41a989adce09969834c

Changed in tripleo:
status: Triaged → In Progress
Revision history for this message
chandan kumar (chkumar246) wrote :

https://review.opendev.org/q/topic:tripleo-zed-jobs updates the job template across tripleo projects.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-heat-templates (master)

Reviewed: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/842675
Committed: https://opendev.org/openstack/tripleo-heat-templates/commit/6c673528f4ec5155db7d14dc207666fbf79581bb
Submitter: "Zuul (22348)"
Branch: master

commit 6c673528f4ec5155db7d14dc207666fbf79581bb
Author: Takashi Kajinami <email address hidden>
Date: Fri May 20 16:32:25 2022 +0900

    Use python job template for Zed

    ... because the current master should be compatible with the Zed
    release of the other projects. This effectively removes testing on
    Python 3.6 and only Python 3.8 and 3.9 will be tested.

    Closes-Bug: #1974244
    Change-Id: I7ceafe711d15a185704eae50852649798c94ccab

Changed in tripleo:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to tripleo-ansible (master)

Reviewed: https://review.opendev.org/c/openstack/tripleo-ansible/+/842680
Committed: https://opendev.org/openstack/tripleo-ansible/commit/88dbecd80df710c4b748e3dd0274f69425d6d1c9
Submitter: "Zuul (22348)"
Branch: master

commit 88dbecd80df710c4b748e3dd0274f69425d6d1c9
Author: Takashi Kajinami <email address hidden>
Date: Fri May 20 16:44:40 2022 +0900

    Use python job template for Zed

    ... because the current master should be compatible with the Zed
    release of the other projects.

    Related-Bug: #1974244
    Change-Id: I05c0cec7e827ec751b3813cd750e7d8799e4020f

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to python-tripleoclient (master)

Reviewed: https://review.opendev.org/c/openstack/python-tripleoclient/+/842679
Committed: https://opendev.org/openstack/python-tripleoclient/commit/7e380a525b202362e1cf03f966836642762c27a5
Submitter: "Zuul (22348)"
Branch: master

commit 7e380a525b202362e1cf03f966836642762c27a5
Author: Takashi Kajinami <email address hidden>
Date: Fri May 20 16:41:28 2022 +0900

    Use python job template for Zed

    ... because the current master should be compatible with the Zed
    release of the other projects. This effectively removes testing on
    Python 3.6 and only Python 3.8 and 3.9 will be tested.

    Python 3.6 and 3.7 are removed form classifiers because these are no
    longer supported.

    Related-Bug: #1974244
    Change-Id: Ibafdb84e5573d74c02874dc0531a6645195a8b5f

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to tripleo-puppet-elements (master)

Reviewed: https://review.opendev.org/c/openstack/tripleo-puppet-elements/+/842681
Committed: https://opendev.org/openstack/tripleo-puppet-elements/commit/c0be3d5bd3b9ed22a8ee10d1d3441fd3996b5c20
Submitter: "Zuul (22348)"
Branch: master

commit c0be3d5bd3b9ed22a8ee10d1d3441fd3996b5c20
Author: Chandan Kumar (raukadah) <email address hidden>
Date: Fri May 20 13:16:17 2022 +0530

    Use python job template for Zed

    the current master should be compatible with the Zed
    release of the other projects.

    Related-Bug: #1974244
    Signed-off-by: Chandan Kumar (raukadah) <email address hidden>
    Change-Id: I7f32d58b596489fd37aee18b04e01035e1ebe77b

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to tripleo-common (master)

Reviewed: https://review.opendev.org/c/openstack/tripleo-common/+/842677
Committed: https://opendev.org/openstack/tripleo-common/commit/933db5dc3b9833e3c5158a6687fde629118d22ba
Submitter: "Zuul (22348)"
Branch: master

commit 933db5dc3b9833e3c5158a6687fde629118d22ba
Author: Takashi Kajinami <email address hidden>
Date: Fri May 20 16:37:30 2022 +0900

    Use python job template for Zed

    ... because the current master should be compatible with the Zed
    release of the other projects. This effectively removes testing on
    Python 3.6 and only Python 3.8 and 3.9 will be tested.

    Python 3.6 and 3.7 are removed form classifiers because these are no
    longer supported.

    Related-Bug: #1974244
    Change-Id: I7fd253cf0c7d09ca3c4ce9b5d069e4c75a985b68

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to tripleo-image-elements (master)

Reviewed: https://review.opendev.org/c/openstack/tripleo-image-elements/+/842682
Committed: https://opendev.org/openstack/tripleo-image-elements/commit/31731e145a0667356ebe7c0aab88ff34602adc8f
Submitter: "Zuul (22348)"
Branch: master

commit 31731e145a0667356ebe7c0aab88ff34602adc8f
Author: Chandan Kumar (raukadah) <email address hidden>
Date: Fri May 20 13:20:26 2022 +0530

    Use python job template for Zed

    the current master should be compatible with the Zed
    release of the other projects.

    Related-Bug: #1974244
    Signed-off-by: Chandan Kumar (raukadah) <email address hidden>
    Change-Id: I4ae059fe095378c3ee3b072b6216908a8988bf26

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to validations-libs (master)

Reviewed: https://review.opendev.org/c/openstack/validations-libs/+/844556
Committed: https://opendev.org/openstack/validations-libs/commit/9047bbb317229a83b6855a22d4c943b6f9aaeada
Submitter: "Zuul (22348)"
Branch: master

commit 9047bbb317229a83b6855a22d4c943b6f9aaeada
Author: matbu <email address hidden>
Date: Fri Jun 3 09:28:48 2022 +0200

    Python 3.6 support removal

    The lowest version of python supported will be Python 3.8,
    to keep up with some of the adjacent components and CI jobs.

    Releated-Bug: #1974244

    Change-Id: I1dda9fc3ab1425403e501ce59211e3828373ee90

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to validations-common (master)

Reviewed: https://review.opendev.org/c/openstack/validations-common/+/844555
Committed: https://opendev.org/openstack/validations-common/commit/64f1e011e6e73bc524716d077d0c94015a3465e6
Submitter: "Zuul (22348)"
Branch: master

commit 64f1e011e6e73bc524716d077d0c94015a3465e6
Author: matbu <email address hidden>
Date: Fri Jun 3 09:27:21 2022 +0200

    Python 3.6 support removal

    The lowest version of python supported will be Python 3.8,
    to keep up with some of the adjacent components and CI jobs.

    Releated-Bug: #1974244

    Change-Id: I513ec696fd769f6fbef3004095898189dbe1721d

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers