[CI][C9][Master] OVB - Cannot install python-heatclient because these package versions have conflicting dependencies

Bug #1967945 reported by Dariusz Smigiel
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Fix Released
Critical
Unassigned

Bug Description

Iestallation of openstack client failes due to conflicting dependencies for python-heatclient
Starting around "2022-04-05 15:37:51" we noticed issues with version mismatch.

The conflict is caused by:
    The user requested python-heatclient
    The user requested (constraint) python-heatclient===2.3.1

Affected jobs
featureset 035 [1][2][3][4][5][6]
featureset 001 [7][8][9][10][11][12]

2022-04-05 18:48:00.478704 | TASK [ovb-manage : Install openstack clients in venv]
2022-04-05 18:49:35.711111 | primary | ERROR
2022-04-05 18:49:35.711381 | primary | {
2022-04-05 18:49:35.711424 | primary | "attempts": 3,
2022-04-05 18:49:35.711456 | primary | "msg": "stdout: Looking in indexes: http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypi/simple, http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-9-x86_64\nCollecting python-openstackclient\n Downloading http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypifiles/packages/fb/21/e3de4025d87da0dcc0441c9acc37079880669f42c733b6a965a94e1161f8/python_openstackclient-5.5.1-py3-none-any.whl (929 kB)\n\nThe conflict is caused by:\n The user requested python-heatclient\n The user requested (constraint) python-heatclient===2.3.1\n\nTo fix this you could try to:\n1. loosen the range of package versions you've specified\n2. remove package versions to allow pip attempt to solve the dependency conflict\n\n\n:stderr: ERROR: Cannot install python-heatclient because these package versions have conflicting dependencies.\nERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependencies\nWARNING: You are using pip version 21.2.3; however, version 21.3.1 is available.\nYou should consider upgrading via the '/home/zuul/workspace/ovb/.venv/bin/python3 -m pip install --upgrade pip' command.\n"

[1]: https://logserver.rdoproject.org/openstack-regular/opendev.org/openstack/tripleo-ci/master/tripleo-ci-centos-9-ovb-3ctlr_1comp-featureset035/df54cba/job-output.txt
[2]: https://logserver.rdoproject.org/openstack-regular/opendev.org/openstack/tripleo-ci/master/tripleo-ci-centos-9-ovb-3ctlr_1comp-featureset035/fc99191/job-output.txt
[3]: https://logserver.rdoproject.org/openstack-regular/opendev.org/openstack/tripleo-ci/master/tripleo-ci-centos-9-ovb-3ctlr_1comp-featureset035/578b0cd/job-output.txt
[4]: https://logserver.rdoproject.org/openstack-regular/opendev.org/openstack/tripleo-ci/master/tripleo-ci-centos-9-ovb-3ctlr_1comp-featureset035/5a23ce4/job-output.txt
[5]: https://logserver.rdoproject.org/openstack-regular/opendev.org/openstack/tripleo-ci/master/tripleo-ci-centos-9-ovb-3ctlr_1comp-featureset035/d62da0b/job-output.txt
[6]: https://logserver.rdoproject.org/openstack-regular/opendev.org/openstack/tripleo-ci/master/tripleo-ci-centos-9-ovb-3ctlr_1comp-featureset035/721db48/job-output.txt

[7]: https://logserver.rdoproject.org/openstack-regular/opendev.org/openstack/tripleo-ci/master/tripleo-ci-centos-9-ovb-3ctlr_1comp-featureset001-wallaby/f2de00d/job-output.txt
[8]: https://logserver.rdoproject.org/openstack-regular/opendev.org/openstack/tripleo-ci/master/tripleo-ci-centos-9-ovb-3ctlr_1comp-featureset001-wallaby/58b36dd/job-output.txt
[9]: https://logserver.rdoproject.org/openstack-regular/opendev.org/openstack/tripleo-ci/master/tripleo-ci-centos-9-ovb-3ctlr_1comp-featureset001-wallaby/aa414ea/job-output.txt
[10]: https://logserver.rdoproject.org/openstack-regular/opendev.org/openstack/tripleo-ci/master/tripleo-ci-centos-9-ovb-3ctlr_1comp-featureset001-wallaby/22a7a3e/job-output.txt
[11]: https://logserver.rdoproject.org/openstack-regular/opendev.org/openstack/tripleo-ci/master/tripleo-ci-centos-9-ovb-3ctlr_1comp-featureset001-wallaby/b82febb/job-output.txt
[12]: https://logserver.rdoproject.org/openstack-regular/opendev.org/openstack/tripleo-ci/master/tripleo-ci-centos-9-ovb-3ctlr_1comp-featureset001-wallaby/a361989/job-output.txt

Revision history for this message
Ronelle Landy (rlandy) wrote :
Revision history for this message
Alan Pevec (apevec) wrote (last edit ):

Description has links for both master and wallaby, where is the issue?

openstackclient 5.5.1 and heatclient 2.3.1 are Wallaby

Revision history for this message
Alan Pevec (apevec) wrote (last edit ):

Can we reproduce this outside the CI job?

Revision history for this message
chandan kumar (chkumar246) wrote :

I was trying to create the reproducer but
```
[root@b9d412d93405 /]# python3 -m venv ovb_repro
[root@b9d412d93405 /]# source ovb_repro/bin/activate
(ovb_repro) [root@b9d412d93405 /]# pip install python-openstackclient python-heatclient python-novaclient python-neutronclient python-glanceclient -c https://raw.githubusercontent.com/openstack/requirements/stable/wallaby/upper-constraints.txt -i http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypi/simple, http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-9-x86_64 --trusted-host mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org
Looking in indexes: http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypi/simple,
Collecting http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-9-x86_64
  ERROR: HTTP error 404 while getting http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-9-x86_64
ERROR: Could not install requirement http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-9-x86_64 because of HTTP error 404 Client Error: Not Found for url: http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-9-x86_64 for URL http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-9-x86_64

```

But http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-9-x86_64 is giving 404. Can we get this mirror back?

Revision history for this message
chandan kumar (chkumar246) wrote :

https://logserver.rdoproject.org/95/40195/3/check/periodic-tripleo-ci-build-containers-centos-9-push-master/e798e3e/job-output.txt

from here,
I am able to reproduce the issue on centos-9 container image
dnf install git-core
git clone https://opendev.org/openstack/tripleo-common
python -m venv repr
source repr/bin/activate
cd tripleo-common/
pip install -r requirements.txt -c https://raw.githubusercontent.com/openstack/requirements/master/upper-constraints.txt -i http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypi/simple --trusted-host mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org

```
repr) [root@3dd84536401a tripleo-common]# pip install -r requirements.txt -c https://raw.githubusercontent.com/openstack/requirements/master/upper-constraints.txt -i http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypi/simple --trusted-host mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org
Looking in indexes: http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypi/simple
Collecting pbr!=2.1.0,>=2.0.0
  Downloading http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypifiles/packages/5a/f0/28b2d5398ed905ce67045670e076c8dfa23ea54c19f2a8e3ac36e8153e1d/pbr-5.8.1-py2.py3-none-any.whl (113 kB)
     |████████████████████████████████| 113 kB 178 kB/s
Collecting GitPython>=1.0.1
  Downloading http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypifiles/packages/fd/05/4b2e29f82f40d3add50956bdb9c868b3608381810b630ea439bb588f558d/GitPython-3.1.24-py3-none-any.whl (180 kB)
     |████████████████████████████████| 180 kB 27.7 MB/s
ERROR: Cannot install python-heatclient>=1.10.0 because these package versions have conflicting dependencies.

The conflict is caused by:
    The user requested python-heatclient>=1.10.0
    The user requested (constraint) python-heatclient===2.5.1

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependencies
WARNING: You are using pip version 21.2.3; however, version 21.3.1 is available.
You should consider upgrading via the '/repr/bin/python3 -m pip install --upgrade pip' command.

Ronelle Landy (rlandy)
Changed in tripleo:
status: Triaged → Fix Released
Revision history for this message
chandan kumar (chkumar246) wrote :
Download full text (3.8 KiB)

In failed job: https://logserver.rdoproject.org/95/40195/3/check/periodic-tripleo-ci-build-containers-centos-9-push-master/e798e3e/job-output.txt

```
2022-04-06 13:29:27.231736 | LOOP [ensure-pip : Run get-pip.py for {{ zj_item }}]
2022-04-06 13:29:30.853309 | primary | Looking in indexes: http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypi/simple, http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-9-x86_64
2022-04-06 13:29:30.853543 | primary | Collecting pip
2022-04-06 13:29:30.853585 | primary | Downloading http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypifiles/packages/a4/6d/6463d49a933f547439d6b5b98b46af8742cc03ae83543e4d7688c2420f8b/pip-21.3.1-py3-none-any.whl (1.7 MB)
2022-04-06 13:29:30.853619 | primary | ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 1.7/1.7 MB 64.8 MB/s eta 0:00:00
2022-04-06 13:29:30.853651 | primary | Collecting wheel
2022-04-06 13:29:30.853682 | primary | Downloading http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypifiles/packages/27/d6/003e593296a85fd6ed616ed962795b2f87709c3eee2bca4f6d0fe55c6d00/wheel-0.37.1-py2.py3-none-any.whl (35 kB)
2022-04-06 13:29:30.853713 | primary | Installing collected packages: wheel, pip
2022-04-06 13:29:30.853743 | primary | WARNING: The script wheel is installed in '/usr/local/bin' which is not on PATH.
2022-04-06 13:29:30.853787 | primary | Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
2022-04-06 13:29:30.853822 | primary | WARNING: The scripts pip, pip3 and pip3.9 are installed in '/usr/local/bin' which is not on PATH.
2022-04-06 13:29:30.853855 | primary | Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
2022-04-06 13:29:30.853886 | primary | Successfully installed pip-21.3.1 wheel-0.37.1
```

and passed on https://review.rdoproject.org/r/c/testproject/+/40195
https://logserver.rdoproject.org/95/40195/3/check/periodic-tripleo-ci-build-containers-centos-9-push-master/85af6c0/job-output.txt

```
LOOP [ensure-pip : Run get-pip.py for {{ zj_item }}]
2022-04-06 14:17:46.684609 | primary | Looking in indexes: http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypi/simple, http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-9-x86_64
2022-04-06 14:17:46.684871 | primary | Collecting pip
2022-04-06 14:17:46.684933 | primary | Downloading http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypifiles/packages/4d/16/0a14ca596f30316efd412a60bdfac02a7259bf8673d4d917dc60b9a21812/pip-22.0.4-py3-none-any.whl (2.1 MB)
2022-04-06 14:17:46.684988 | primary | ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 2.1/2.1 MB 35.1 MB/s eta 0:00:00
2022-04-06 14:17:46.685043 | primary | Collecting wheel
2022-04-06 14:17:46.685097 | primary | Downloading http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypifiles/packages/27/d6/003e593296a85fd6ed616ed962795b2f87709c3eee2bca4f6d0fe55c6d00/wheel-0.37.1-py2.py3-none-any.whl (35 kB)
2022-04-06 14:17:46.685150 | primary | Installing collected packages: wheel, pip
2022-04-...

Read more...

Revision history for this message
Alan Pevec (apevec) wrote :

so, BAD pip-21.3.1 GOOD pip-22.0.4 (2022-03-06)
but why was it picking 21.3.1 (2021-10-22) at 2022-04-06 13:29 ??
https://pip.pypa.io/en/stable/news/#v21-3-1

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers