[CI][C8][Wallaby] The conflict caused by oslo-config

Bug #1967943 reported by Dariusz Smigiel
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Fix Released
Critical
Unassigned

Bug Description

Jobs for featureset001 and featureset035 started failing due [1][2][3].
Last job, which we noticed, without this issue is dated on "2022-04-05 11:38:20". Consecutive jobs, starting from "2022-04-05 15:45:31" [4] started exposing this issue.

2022-04-05 18:15:23.201137 | primary | Collecting ansible-core<2.12,>=2.11
2022-04-05 18:15:23.207596 | primary | Downloading http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypifiles/packages/68/b1/551c421c3ce322ccf221b619ea61ec862dc34b08ebb76580fd71709c5e36/ansible-core-2.11.9.tar.gz (7.1 MB)
2022-04-05 18:15:24.816728 | primary | Preparing metadata (setup.py): started
2022-04-05 18:15:25.295645 | primary | Preparing metadata (setup.py): finished with status 'done'
2022-04-05 18:15:25.303233 | primary | INFO: pip is looking at multiple versions of <Python from Requires-Python> to determine which version is compatible with other requirements. This could take a while.
2022-04-05 18:15:25.304110 | primary | INFO: pip is looking at multiple versions of cmd2 to determine which version is compatible with other requirements. This could take a while.
2022-04-05 18:15:25.304740 | primary | ERROR: Cannot install -r requirements.txt (line 18) because these package versions have conflicting dependencies.
2022-04-05 18:15:25.305043 | primary |
2022-04-05 18:15:25.305079 | primary | The conflict is caused by:
2022-04-05 18:15:25.305123 | primary | oslo-config 8.5.1 depends on stevedore>=1.20.0
2022-04-05 18:15:25.305141 | primary | The user requested (constraint) stevedore===3.3.1

[1]: https://logserver.rdoproject.org/78/41278/8/check/periodic-tripleo-ci-centos-8-ovb-3ctlr_1comp-featureset001-wallaby/b564518/job-output.txt
[2]: https://logserver.rdoproject.org/78/41278/8/check/periodic-tripleo-ci-centos-8-ovb-3ctlr_1comp-featureset035-wallaby/c20e169/job-output.txt
[3]: https://logserver.rdoproject.org/42/40642/4/check/periodic-tripleo-ci-centos-8-ovb-3ctlr_1comp-featureset001-network-wallaby/f4cd7d0/job-output.txt
[4]: https://logserver.rdoproject.org/60/39960/24/check/periodic-tripleo-ci-centos-8-ovb-3ctlr_1comp-featureset035-wallaby/91952fd/job-output.txt

Revision history for this message
Ronelle Landy (rlandy) wrote :

Possibly clearing - first OVB on centos 8 started running

Revision history for this message
chandan kumar (chkumar246) wrote :

By using this log: https://logserver.rdoproject.org/openstack-component-tripleo/opendev.org/openstack/tripleo-ci/master/periodic-tripleo-ci-centos-8-standalone-upgrade-tripleo-wallaby/18d7d43/job-output.txt

and the error is coming at this step
```
 Running in bootstrap: python3 -m pip install --force-reinstall -r requirements.txt -r quickstart-extras-requirements.txt
2022-04-05 20:32:05.104037 | primary | Looking in indexes: http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypi/simple, http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-8-x86_64
```

I was trying to create a reproducer
1. git clone https://opendev.org/openstack/tripleo-quickstart
2. cd tripleo-quickstart/
3. python3 -m venv tq_venv
4. source tq_venv/bin/activate
5. python3 -m pip install --force-reinstall -r requirements.txt -r quickstart-extras-requirements.txt -i http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypi/simple, http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-8-x86_64 --trusted-host mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org

```
(tq_venv) [root@9f343213098e tripleo-quickstart]# python3 -m pip install --force-reinstall -r requirements.txt -r quickstart-extras-requirements.txt -i http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypi/simple, http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-8-x86_64 --trusted-host mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org
Looking in indexes: http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/pypi/simple,
Collecting http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-8-x86_64
  Downloading http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-8-x86_64 (15 kB)
  ERROR: Cannot unpack file /tmp/pip-unpack-7b7cvjrb/centos-8-x86_64 (downloaded from /tmp/pip-req-build-6m3qq_62, content-type: text/html; charset=UTF-8); cannot detect archive format
ERROR: Cannot determine archive format of /tmp/pip-req-build-6m3qq_62

```

and after that I removed http://mirror.regionone.vexxhost-nodepool-tripleo.rdoproject.org/wheel/centos-8-x86_64 and re-runned the above command it is working fine

I am not able to reproduce the issue locally with above indexes.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to tripleo-quickstart-extras (master)
Ronelle Landy (rlandy)
Changed in tripleo:
status: Triaged → Fix Released
Amol Kahat (amolkahat)
information type: Public → Public Security
information type: Public Security → Private Security
information type: Private Security → Private
Revision history for this message
Jeremy Stanley (fungi) wrote :

Switched back to public since it looks like someone was playing with the information type setting. If this bug is really sensitive enough that it needs to be private, please add a comment explaining why you're altering its type. Also, it's sort of pointless to switch a public bug to private since so many accounts are subscribed to this project and already got copies of everything via E-mail.

information type: Private → Public
Revision history for this message
Amol Kahat (amolkahat) wrote :

Apologies, It's not intentional, it's mistake.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on tripleo-quickstart-extras (master)

Change abandoned by "Arx Cruz <email address hidden>" on branch: master
Review: https://review.opendev.org/c/openstack/tripleo-quickstart-extras/+/836817
Reason: It seems it's no longer an issue

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers