ovndb_server is not restarted as expected during minor update

Bug #1931502 reported by Damien Ciabrini
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Damien Ciabrini

Bug Description

Since we moved pcs restart actions on the host [1], we have introducted a typo in the handling of ovn_dbs HA resource. Consequently, a configuration change doesn't restart the ovn_dbs resource as expected:

[root@controller-2 lib64]# TRIPLEO_MINOR_UPDATE=true /var/lib/container-config-scripts/pacemaker_restart_bundle.sh ovn_dbs ovndbs_servers ovn-dbs-bundle Slave Master
Wed Jun 9 19:53:33 UTC 2021: Restarting ovn-dbs-bundle locally on 'controller-2'
ovn-dbs-bundle successfully restarted
Wed Jun 9 19:53:39 UTC 2021: Waiting until ovndbs_servers has restarted on controller-2 and is in state Slave
Wed Jun 9 19:53:39 UTC 2021: Will probe resource state with the following XPath pattern: //bundle/replica/resource[@resource_agent='ocf::pacemaker:remote']/node[@name='controller-2']/../../resource[@id='ovndbs_servers']
Wed Jun 9 19:53:40 UTC 2021: Waiting for ovndbs_servers to transition to role Slave on controller-2
Wed Jun 9 19:53:45 UTC 2021: Waiting for ovndbs_servers to transition to role Slave on controller-2
Wed Jun 9 19:53:50 UTC 2021: Waiting for ovndbs_servers to transition to role Slave on controller-2
Wed Jun 9 19:53:54 UTC 2021: Waiting for ovndbs_servers to transition to role Slave on controller-2
Wed Jun 9 19:53:59 UTC 2021: Waiting for ovndbs_servers to transition to role Slave on controller-2

This is due to the resource being called ovndbs_servers instead of ovndb_servers

[1] I918b6c16db6ed70d9ad612aecd7af7d725520f7b

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-heat-templates (master)
Changed in tripleo:
status: Confirmed → In Progress
Changed in tripleo:
importance: Undecided → High
tags: added: train-backport-potential
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-heat-templates (master)

Reviewed: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/795706
Committed: https://opendev.org/openstack/tripleo-heat-templates/commit/6837633ea4075c1e74281ade7005cb8325b51f5a
Submitter: "Zuul (22348)"
Branch: master

commit 6837633ea4075c1e74281ade7005cb8325b51f5a
Author: Damien Ciabrini <email address hidden>
Date: Wed Jun 9 23:52:13 2021 +0200

    Fix broken restart of ovndb_server during minor update

    Since [1], the ovn HA resource is mistakenly called
    ovndbs_servers instead of ovndb_servers, which breaks
    its restart during a minor update. Fix the typo.

    [1] I918b6c16db6ed70d9ad612aecd7af7d725520f7b

    Change-Id: I2cd08a7b195620e6c93084a6a689bad1d6ace179
    Closes-Bug: #1931502

Changed in tripleo:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-heat-templates (stable/wallaby)

Fix proposed to branch: stable/wallaby
Review: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/795886

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-heat-templates (stable/wallaby)

Reviewed: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/795886
Committed: https://opendev.org/openstack/tripleo-heat-templates/commit/1ff7e9be9d9c763acc7cd5ae11b2c7580daa737f
Submitter: "Zuul (22348)"
Branch: stable/wallaby

commit 1ff7e9be9d9c763acc7cd5ae11b2c7580daa737f
Author: Damien Ciabrini <email address hidden>
Date: Wed Jun 9 23:52:13 2021 +0200

    Fix broken restart of ovndb_server during minor update

    Since [1], the ovn HA resource is mistakenly called
    ovndbs_servers instead of ovndb_servers, which breaks
    its restart during a minor update. Fix the typo.

    [1] I918b6c16db6ed70d9ad612aecd7af7d725520f7b

    Change-Id: I2cd08a7b195620e6c93084a6a689bad1d6ace179
    Closes-Bug: #1931502
    (cherry picked from commit 6837633ea4075c1e74281ade7005cb8325b51f5a)

tags: added: in-stable-wallaby
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-heat-templates (stable/victoria)

Fix proposed to branch: stable/victoria
Review: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/796077

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-heat-templates (stable/victoria)

Reviewed: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/796077
Committed: https://opendev.org/openstack/tripleo-heat-templates/commit/6c5011056ee5ae21e96f0435bf9e24f59922f515
Submitter: "Zuul (22348)"
Branch: stable/victoria

commit 6c5011056ee5ae21e96f0435bf9e24f59922f515
Author: Damien Ciabrini <email address hidden>
Date: Wed Jun 9 23:52:13 2021 +0200

    Fix broken restart of ovndb_server during minor update

    Since [1], the ovn HA resource is mistakenly called
    ovndbs_servers instead of ovndb_servers, which breaks
    its restart during a minor update. Fix the typo.

    [1] I918b6c16db6ed70d9ad612aecd7af7d725520f7b

    Change-Id: I2cd08a7b195620e6c93084a6a689bad1d6ace179
    Closes-Bug: #1931502
    (cherry picked from commit 6837633ea4075c1e74281ade7005cb8325b51f5a)
    (cherry picked from commit 1ff7e9be9d9c763acc7cd5ae11b2c7580daa737f)

tags: added: in-stable-victoria
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-heat-templates (stable/ussuri)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-heat-templates (stable/ussuri)

Reviewed: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/796206
Committed: https://opendev.org/openstack/tripleo-heat-templates/commit/a56ab848c53f2f9c51bd13511f3b5d48094a8a34
Submitter: "Zuul (22348)"
Branch: stable/ussuri

commit a56ab848c53f2f9c51bd13511f3b5d48094a8a34
Author: Damien Ciabrini <email address hidden>
Date: Wed Jun 9 23:52:13 2021 +0200

    Fix broken restart of ovndb_server during minor update

    Since [1], the ovn HA resource is mistakenly called
    ovndbs_servers instead of ovndb_servers, which breaks
    its restart during a minor update. Fix the typo.

    [1] I918b6c16db6ed70d9ad612aecd7af7d725520f7b

    Change-Id: I2cd08a7b195620e6c93084a6a689bad1d6ace179
    Closes-Bug: #1931502
    (cherry picked from commit 6837633ea4075c1e74281ade7005cb8325b51f5a)
    (cherry picked from commit 1ff7e9be9d9c763acc7cd5ae11b2c7580daa737f)
    (cherry picked from commit 6c5011056ee5ae21e96f0435bf9e24f59922f515)

tags: added: in-stable-ussuri
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-heat-templates (stable/train)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on tripleo-heat-templates (stable/train)

Change abandoned by "wes hayutin <email address hidden>" on branch: stable/train
Review: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/796213
Reason: stuck in gate

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-heat-templates (stable/train)

Reviewed: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/796213
Committed: https://opendev.org/openstack/tripleo-heat-templates/commit/e53581fcd3a80cd78c2429380568b6f4e07c1a9e
Submitter: "Zuul (22348)"
Branch: stable/train

commit e53581fcd3a80cd78c2429380568b6f4e07c1a9e
Author: Damien Ciabrini <email address hidden>
Date: Wed Jun 9 23:52:13 2021 +0200

    Fix broken restart of ovndb_server during minor update

    Since [1], the ovn HA resource is mistakenly called
    ovndbs_servers instead of ovndb_servers, which breaks
    its restart during a minor update. Fix the typo.

    [1] I918b6c16db6ed70d9ad612aecd7af7d725520f7b

    Change-Id: I2cd08a7b195620e6c93084a6a689bad1d6ace179
    Closes-Bug: #1931502
    (cherry picked from commit 6837633ea4075c1e74281ade7005cb8325b51f5a)
    (cherry picked from commit 1ff7e9be9d9c763acc7cd5ae11b2c7580daa737f)
    (cherry picked from commit 6c5011056ee5ae21e96f0435bf9e24f59922f515)
    (cherry picked from commit a56ab848c53f2f9c51bd13511f3b5d48094a8a34)

tags: added: in-stable-train
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-heat-templates 14.2.0

This issue was fixed in the openstack/tripleo-heat-templates 14.2.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-heat-templates 13.4.0

This issue was fixed in the openstack/tripleo-heat-templates 13.4.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-heat-templates 12.4.5

This issue was fixed in the openstack/tripleo-heat-templates 12.4.5 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers