overcloud nodes network manager hangs because ifcfg-eth0 is defined

Bug #1931495 reported by Alex Schultz
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Alex Schultz

Bug Description

the overcloud-full images end up having an ifcfg-eth0 network script which can cause NetworkManager to fail if the node does not have eth0. This shows up after node provisioning where the nodes are up but the IPs are not available.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-image-elements (master)
Changed in tripleo:
status: Triaged → In Progress
Changed in tripleo:
assignee: nobody → Alex Schultz (alex-schultz)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-image-elements (master)

Reviewed: https://review.opendev.org/c/openstack/tripleo-image-elements/+/795696
Committed: https://opendev.org/openstack/tripleo-image-elements/commit/f90a830fbac3b9ac1e501a768eeb7454e4d540f8
Submitter: "Zuul (22348)"
Branch: master

commit f90a830fbac3b9ac1e501a768eeb7454e4d540f8
Author: Alex Schultz <email address hidden>
Date: Wed Jun 9 14:32:22 2021 -0600

    Clean up ifcfg-eth0

    If ifcfg-eth0 is defined but does not exist, this can cause the nodes to
    fail to get an IP address on initial provisioning. This patch removes it
    when the image is built to ensure we don't end up with a bad interface
    network script.

    Change-Id: I3b8cb5f8c413c109da1228878db9cff4d439273b
    Closes-Bug: #1931495

Changed in tripleo:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-image-elements (stable/wallaby)

Fix proposed to branch: stable/wallaby
Review: https://review.opendev.org/c/openstack/tripleo-image-elements/+/795806

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-image-elements (stable/victoria)

Fix proposed to branch: stable/victoria
Review: https://review.opendev.org/c/openstack/tripleo-image-elements/+/795807

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-image-elements (stable/victoria)

Reviewed: https://review.opendev.org/c/openstack/tripleo-image-elements/+/795807
Committed: https://opendev.org/openstack/tripleo-image-elements/commit/6fd9757b189732d5e0b6a27eed7f03c1eb2dd71e
Submitter: "Zuul (22348)"
Branch: stable/victoria

commit 6fd9757b189732d5e0b6a27eed7f03c1eb2dd71e
Author: Alex Schultz <email address hidden>
Date: Wed Jun 9 14:32:22 2021 -0600

    Clean up ifcfg-eth0

    If ifcfg-eth0 is defined but does not exist, this can cause the nodes to
    fail to get an IP address on initial provisioning. This patch removes it
    when the image is built to ensure we don't end up with a bad interface
    network script.

    Change-Id: I3b8cb5f8c413c109da1228878db9cff4d439273b
    Closes-Bug: #1931495
    (cherry picked from commit f90a830fbac3b9ac1e501a768eeb7454e4d540f8)

tags: added: in-stable-victoria
tags: added: in-stable-wallaby
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-image-elements (stable/wallaby)

Reviewed: https://review.opendev.org/c/openstack/tripleo-image-elements/+/795806
Committed: https://opendev.org/openstack/tripleo-image-elements/commit/fb4c3621f45ddc1bc83a32a7c9c55455dc63b88a
Submitter: "Zuul (22348)"
Branch: stable/wallaby

commit fb4c3621f45ddc1bc83a32a7c9c55455dc63b88a
Author: Alex Schultz <email address hidden>
Date: Wed Jun 9 14:32:22 2021 -0600

    Clean up ifcfg-eth0

    If ifcfg-eth0 is defined but does not exist, this can cause the nodes to
    fail to get an IP address on initial provisioning. This patch removes it
    when the image is built to ensure we don't end up with a bad interface
    network script.

    Change-Id: I3b8cb5f8c413c109da1228878db9cff4d439273b
    Closes-Bug: #1931495
    (cherry picked from commit f90a830fbac3b9ac1e501a768eeb7454e4d540f8)

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-image-elements 14.0.0

This issue was fixed in the openstack/tripleo-image-elements 14.0.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-image-elements 13.1.2

This issue was fixed in the openstack/tripleo-image-elements 13.1.2 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-image-elements 12.2.2

This issue was fixed in the openstack/tripleo-image-elements 12.2.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers