Sc10 / sc10-kvm / Sc010-ovn-provider failing with "(pymysql.err.ProgrammingError) (1146, \"Table 'octavia.quotas' doesn't exist\"

Bug #1931428 reported by Sandeep Yadav
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Unassigned

Bug Description

Description:-

Sc10 / sc10-kvm / Sc010-ovn-provider failing with "(pymysql.err.ProgrammingError) (1146, \"Table 'octavia.quotas' doesn't exist\"

https://logserver.rdoproject.org/openstack-periodic-integration-main/opendev.org/openstack/tripleo-ci/master/periodic-tripleo-ci-centos-8-scenario010-ovn-provider-standalone-master/0a2a19e/logs/undercloud/var/log/tempest/tempest_run.log.txt.gz
~~~
    Details: b'{"faultcode": "Server", "faultstring": "(pymysql.err.ProgrammingError) (1146, \\"Table \'octavia.quotas\' doesn\'t exist\\")\\n[SQL: SELECT quotas.project_id AS quotas_project_id, quotas.health_monitor AS quotas_health_monitor, quotas.listener AS quotas_listener, quotas.load_balancer AS quotas_load_balancer, quotas.`member` AS quotas_member, quotas.pool AS quotas_pool, quotas.l7policy AS quotas_l7policy, quotas.l7rule AS quotas_l7rule, quotas.in_use_health_monitor AS quotas_in_use_health_monitor, quotas.in_use_listener AS quotas_in_use_listener, quotas.in_use_load_balancer AS quotas_in_use_load_balancer, quotas.in_use_member AS quotas_in_use_member, quotas.in_use_pool AS quotas_in_use_pool, quotas.in_use_l7policy AS quotas_in_use_l7policy, quotas.in_use_l7rule AS quotas_in_use_l7rule \\nFROM quotas \\nWHERE quotas.project_id = %(project_id_1)s \\n LIMIT %(param_1)s]\\n[parameters: {\'project_id_1\': \'4f50a37c9d2c4b7eac4bf9b469535ce5\', \'param_1\': 1}]\\n(Background on this error at: http://sqlalche.me/e/13/f405)", "debuginfo": null}'
~~~

https://logserver.rdoproject.org/openstack-periodic-integration-main/opendev.org/openstack/tripleo-ci/master/periodic-tripleo-ci-centos-8-scenario010-standalone-master/2baa3e1/logs/undercloud/var/log/tempest/stestr_results.html.gz

https://logserver.rdoproject.org/openstack-periodic-integration-main/opendev.org/openstack/tripleo-ci/master/periodic-tripleo-ci-centos-8-scenario010-standalone-master/2baa3e1/logs/undercloud/var/log/tempest/stestr_results.html.gz

Last good run on 07th June:-

https://review.rdoproject.org/zuul/builds?job_name=periodic-tripleo-ci-centos-8-scenario010-standalone-master

Changed in tripleo:
status: Triaged → In Progress
Revision history for this message
Brent Eagles (beagles) wrote (last edit ):

I think this was caused by a typo in a recent patch that broke the db_sync for octavia.

See patch https://review.opendev.org/c/openstack/tripleo-heat-templates/+/795590

wes hayutin (weshayutin)
Changed in tripleo:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-heat-templates (master)

Reviewed: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/795590
Committed: https://opendev.org/openstack/tripleo-heat-templates/commit/6e67e7377e89fd9eb1da73eff6fa8b7c756718bc
Submitter: "Zuul (22348)"
Branch: master

commit 6e67e7377e89fd9eb1da73eff6fa8b7c756718bc
Author: Brent Eagles <email address hidden>
Date: Wed Jun 9 13:50:56 2021 -0230

    Fix typo that breaks Octavia db sync step

    The filename for the kolla_config octavia json file was incorrect
    causing there to be no database initialization for octavia deployments.

    Closes-Bug: #1931428
    Change-Id: Ic18f07f01a2b4053d042dc0a1b783b397d985d9e

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-heat-templates 15.0.0

This issue was fixed in the openstack/tripleo-heat-templates 15.0.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-heat-templates (stable/wallaby)

Fix proposed to branch: stable/wallaby
Review: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/796724

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-heat-templates (stable/wallaby)

Reviewed: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/796724
Committed: https://opendev.org/openstack/tripleo-heat-templates/commit/4758c3e7ced1970b96cb36b180484f790f6d3644
Submitter: "Zuul (22348)"
Branch: stable/wallaby

commit 4758c3e7ced1970b96cb36b180484f790f6d3644
Author: Brent Eagles <email address hidden>
Date: Wed Jun 9 13:50:56 2021 -0230

    Fix typo that breaks Octavia db sync step

    The filename for the kolla_config octavia json file was incorrect
    causing there to be no database initialization for octavia deployments.

    Closes-Bug: #1931428
    Change-Id: Ic18f07f01a2b4053d042dc0a1b783b397d985d9e
    (cherry picked from commit 6e67e7377e89fd9eb1da73eff6fa8b7c756718bc)

tags: added: in-stable-wallaby
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-heat-templates 14.2.0

This issue was fixed in the openstack/tripleo-heat-templates 14.2.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers