undercloud install includes useless environments/services/undercloud-keepalived.yaml

Bug #1926314 reported by Takashi Kajinami
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Low
Takashi Kajinami

Bug Description

Description
===========
Currently undercloud install includes environments/services/undercloud-keepalived.yaml
when generate_service_certificate or undercloud_service_certificate is True.

https://github.com/openstack/python-tripleoclient/blob/fd018512578a2c4bbc1396ab03d2a4e818dc7064/tripleoclient/v1/undercloud_config.py#L756-L758

However this template is ineffective since Keepalived service was removed
from roles_data_undercloud.yaml by the following change.
 https://github.com/openstack/tripleo-heat-templates/commit/c712355e4bae4ef2fc1b83e5603c0364dbd50a78

Steps to reproduce
===========
- Install undercloud with generate_service_certificate=True

Expected result
===============
- the following template is not included in the command line of tripleo deploy command
 /usr/share/openstack-tripleo-heat-templates/environments/services/undercloud-keepalived.yaml

Actual result
===============
- the template file is included in the command line

Environment
===============
This issue is observed in upstream CI for master branch

Logs & Configs
===============
An example can be found here
 https://zuul.opendev.org/t/openstack/build/0bc77621aa9f404bb7d11932a0244433/log/logs/undercloud/home/zuul/undercloud_install.log#2

description: updated
Changed in tripleo:
status: New → In Progress
Revision history for this message
Takashi Kajinami (kajinamit) wrote :
Changed in tripleo:
assignee: nobody → Takashi Kajinami (kajinamit)
importance: Undecided → Low
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to python-tripleoclient (master)

Reviewed: https://review.opendev.org/c/openstack/python-tripleoclient/+/788200
Committed: https://opendev.org/openstack/python-tripleoclient/commit/b02acaa6e17e8c3d1ab29ab30fa21e8b65ba8b43
Submitter: "Zuul (22348)"
Branch: master

commit b02acaa6e17e8c3d1ab29ab30fa21e8b65ba8b43
Author: Takashi Kajinami <email address hidden>
Date: Tue Apr 27 17:07:52 2021 +0900

    Remove leftover for undercloud keepalived service

    Currently environments/services/undercloud-keepalived.yaml is included
    when undercloud SSL is enabled but this file is no longer effective
    since the Keepalived service was removed from undercloud role data[1].

    [1] c712355e4bae4ef2fc1b83e5603c0364dbd50a78

    Because VIPs are managed by os-net-config now and we don't expect any
    situation where users requires keepalived running in undercloud,
    this change simply removes all remaining implementation for undercloud
    keepalived service.

    Closes-Bug: #1926314
    Change-Id: I9d9dea09a36914cffaef1d251c49f3c4fea4fa68

Changed in tripleo:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to tripleo-heat-templates (master)

Reviewed: https://review.opendev.org/c/openstack/tripleo-heat-templates/+/788095
Committed: https://opendev.org/openstack/tripleo-heat-templates/commit/acafd67c391c53f59901cb5f70dc4d7425f6403a
Submitter: "Zuul (22348)"
Branch: master

commit acafd67c391c53f59901cb5f70dc4d7425f6403a
Author: Takashi Kajinami <email address hidden>
Date: Tue Apr 27 08:12:19 2021 +0900

    Remove Keepalived service

    The Keepalived service was deprecated during the Ussuri cycle[1], so
    can be removed now.

    [1] c712355e4bae4ef2fc1b83e5603c0364dbd50a78

    Related-Bug: #1926314
    Depends-on: https://review.opendev.org/788200
    Change-Id: I02a2612c7e08576c7c5df85e73702a5678a18b99

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to tripleo-common (master)

Reviewed: https://review.opendev.org/c/openstack/tripleo-common/+/788097
Committed: https://opendev.org/openstack/tripleo-common/commit/9793ddde701f37ff608dbcb5e9ef8023c458be5c
Submitter: "Zuul (22348)"
Branch: master

commit 9793ddde701f37ff608dbcb5e9ef8023c458be5c
Author: Takashi Kajinami <email address hidden>
Date: Tue Apr 27 08:23:33 2021 +0900

    Remove Keepalived service

    The Keepalived servier has been remove completely so any definition for
    the service can be removed now.

    Related-Bug: #1926314
    Depends-on: https://review.opendev.org/788200
    Depends-on: https://review.opendev.org/788095
    Change-Id: I01b066aefa6b7d6bd0cf69dbe5327db6934d6d6e

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to python-tripleoclient (stable/wallaby)

Fix proposed to branch: stable/wallaby
Review: https://review.opendev.org/c/openstack/python-tripleoclient/+/788922

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to puppet-tripleo (master)

Reviewed: https://review.opendev.org/c/openstack/puppet-tripleo/+/788096
Committed: https://opendev.org/openstack/puppet-tripleo/commit/573832124a6de8cdca08f6cbf073ea5b3575bd73
Submitter: "Zuul (22348)"
Branch: master

commit 573832124a6de8cdca08f6cbf073ea5b3575bd73
Author: Takashi Kajinami <email address hidden>
Date: Tue Apr 27 08:17:06 2021 +0900

    Remove the manifest for the Keepalived service

    ... because the service is removed from tripleo-heat-templates.

    Related-Bug: #1926314
    Depends-on: https://review.opendev.org/788200
    Depends-on: https://review.opendev.org/788095
    Change-Id: Ibc9911b62f8131fbe8dd9e061e61c56a4e5d301e

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to tripleo-common (stable/wallaby)

Related fix proposed to branch: stable/wallaby
Review: https://review.opendev.org/c/openstack/tripleo-common/+/790107

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to python-tripleoclient (stable/wallaby)

Reviewed: https://review.opendev.org/c/openstack/python-tripleoclient/+/788922
Committed: https://opendev.org/openstack/python-tripleoclient/commit/a447a5fbbdeb343e1815793bfbab1216e51903d3
Submitter: "Zuul (22348)"
Branch: stable/wallaby

commit a447a5fbbdeb343e1815793bfbab1216e51903d3
Author: Takashi Kajinami <email address hidden>
Date: Tue Apr 27 17:07:52 2021 +0900

    Remove leftover for undercloud keepalived service

    Currently environments/services/undercloud-keepalived.yaml is included
    when undercloud SSL is enabled but this file is no longer effective
    since the Keepalived service was removed from undercloud role data[1].

    [1] c712355e4bae4ef2fc1b83e5603c0364dbd50a78

    Because VIPs are managed by os-net-config now and we don't expect any
    situation where users requires keepalived running in undercloud,
    this change simply removes all remaining implementation for undercloud
    keepalived service.

    Closes-Bug: #1926314
    Change-Id: I9d9dea09a36914cffaef1d251c49f3c4fea4fa68
    (cherry picked from commit b02acaa6e17e8c3d1ab29ab30fa21e8b65ba8b43)

tags: added: in-stable-wallaby
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to tripleo-common (stable/wallaby)

Reviewed: https://review.opendev.org/c/openstack/tripleo-common/+/790107
Committed: https://opendev.org/openstack/tripleo-common/commit/3d3ccdb7452fa6f737bcd86c0311b4f5bf1e315a
Submitter: "Zuul (22348)"
Branch: stable/wallaby

commit 3d3ccdb7452fa6f737bcd86c0311b4f5bf1e315a
Author: Takashi Kajinami <email address hidden>
Date: Tue Apr 27 08:23:33 2021 +0900

    Remove Keepalived service

    The Keepalived servier has been remove completely so any definition for
    the service can be removed now.

    Related-Bug: #1926314
    Depends-on: https://review.opendev.org/788200
    Depends-on: https://review.opendev.org/788095
    Change-Id: I01b066aefa6b7d6bd0cf69dbe5327db6934d6d6e

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/python-tripleoclient 16.2.0

This issue was fixed in the openstack/python-tripleoclient 16.2.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/python-tripleoclient 17.0.0

This issue was fixed in the openstack/python-tripleoclient 17.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers