Placement endpoint check fails with 'NoneType' is not iterable

Bug #1913416 reported by Oliver Walsh
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Undecided
Oliver Walsh

Bug Description

Related to https: //bugs.launchpad.net/tripleo/+bug/1870528.
Related Red Hat BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1911653

The placement endpoint check assumes and empty dict is returned when no endpoints are set, however None is returned. This results in a 'NoneType' is not iterable exception which cannot be resolved without modifying the heat resource or the tripleo-common code.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-common 13.2.0

This issue was fixed in the openstack/tripleo-common 13.2.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-common 11.6.0

This issue was fixed in the openstack/tripleo-common 11.6.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-common 12.4.4

This issue was fixed in the openstack/tripleo-common 12.4.4 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-common 15.0.0

This issue was fixed in the openstack/tripleo-common 15.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers