HorizonDebug is not correctly honored

Bug #1908362 reported by Takashi Kajinami on 2020-12-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Undecided
Takashi Kajinami

Bug Description

Currently Debug parameters(Debug and HorizonDebug) are used to set horizon::django_debug and horizon::log_level but there are some problems with the current implementation.

1. HorizonDebug is ineffective for horizon::django_debug, because of inproper conditions debug_unset which is always True.

2. When Horizon: true and HorizonDebug: false are set, horizon::log_level is set to DEBUG, while we
generally expect that service specific debug parameters override the common debug parameter.

Revision history for this message
Marios Andreou (marios-b) wrote :

Fix from Takashi at

        * Fix logic to honor HorizonDebug
        * Change-Id: I514b5a3d4133d3561376ea06a803d019acaa0f0b
        * https://review.opendev.org/c/openstack/tripleo-heat-templates/+/767281

Revision history for this message
Marios Andreou (marios-b) wrote :
Revision history for this message
Marios Andreou (marios-b) wrote :

test review @

        * DNM: Test behavior of HorizonDebug
        * Change-Id: I19dc259e455456a01718f2c5c3e3086bea95588c
        * https://review.opendev.org/c/openstack/tripleo-heat-templates/+/768177

Revision history for this message
Takashi Kajinami (kajinamit) wrote :

Thank you, Marios, for posting these information.

Let me correct one mistake I made in my original comment.

> I confirmed that debug is disabled as expected in CI result (because we have Debug:true set)
I should have said;

I confirmed that debug is ENABLED as expected in CI result (because we have Debug:true set)

Changed in tripleo:
assignee: nobody → Takashi Kajinami (kajinamit)
status: New → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-heat-templates 14.0.0

This issue was fixed in the openstack/tripleo-heat-templates 14.0.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-heat-templates 11.5.0

This issue was fixed in the openstack/tripleo-heat-templates 11.5.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-heat-templates 12.4.3

This issue was fixed in the openstack/tripleo-heat-templates 12.4.3 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers