[tripleo-ansible] py* jobs broken with new pip

Bug #1908079 reported by Rabi Mishra
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Alex Schultz

Bug Description

Noticed at:

https://b6882f7bddde177cc17f-f63b2c309fc0040fbb4a377b77794f40.ssl.cf5.rackcdn.com/766789/1/check/openstack-tox-py36/babbcd8/job-output.txt

2020-12-11 20:42:28.940184 | TASK [Run tox without tests]
2020-12-11 20:42:29.703296 | ubuntu-bionic | py36 create: /home/zuul/src/opendev.org/openstack/tripleo-ansible/.tox/py36
2020-12-11 20:42:30.283155 | ubuntu-bionic | py36 installdeps: -r/home/zuul/src/opendev.org/openstack/tripleo-ansible/test-requirements.txt, -r/home/zuul/src/opendev.org/openstack/tripleo-ansible/ansible-requirements.txt
2020-12-11 20:42:31.796928 | ubuntu-bionic | ERROR: invocation failed (exit code 1), logfile: /home/zuul/src/opendev.org/openstack/tripleo-ansible/.tox/py36/log/py36-1.log
2020-12-11 20:42:31.797936 | ubuntu-bionic | ================================== log start ===================================
2020-12-11 20:42:31.797982 | ubuntu-bionic | Looking in indexes: https://mirror.bhs1.ovh.opendev.org/pypi/simple, https://mirror.bhs1.ovh.opendev.org/wheel/ubuntu-18.04-x86_64
2020-12-11 20:42:31.798001 | ubuntu-bionic | DEPRECATION: Constraints are only allowed to take the form of a package name and a version specifier. Other forms were originally permitted as an accident of the implementation, but were undocumented. The new implementation of the resolver no longer supports these forms. A possible replacement is replacing the constraint with a requirement.. You can find discussion regarding this at https://github.com/pypa/pip/issues/8210.
2020-12-11 20:42:31.798019 | ubuntu-bionic | ERROR: Links are not allowed as constraints
2020-12-11 20:42:31.798028 | ubuntu-bionic |
2020-12-11 20:42:31.798148 | ubuntu-bionic | =================================== log end ====================================
2020-12-11 20:42:31.798628 | ubuntu-bionic | ERROR: could not install deps [-r/home/zuul/src/opendev.org/openstack/tripleo-ansible/test-requirements.txt, -r/home/zuul/src/opendev.org/openstack/tripleo-ansible/ansible-requirements.txt]; v = InvocationError('/home/zuul/src/opendev.org/openstack/tripleo-ansible/.tox/py36/bin/python3 -m pip install -c/home/zuul/src/opendev.org/openstack/requirements/upper-constraints.txt -c/home/zuul/src/opendev.org/openstack/tripleo-ansible/constraints.txt -r/home/zuul/src/opendev.org/openstack/tripleo-ansible/test-requirements.txt -r/home/zuul/src/opendev.org/openstack/tripleo-ansible/ansible-requirements.txt', 1)
2020-12-11 20:42:31.798911 | ubuntu-bionic | ___________________________________ summary ____________________________________
2020-12-11 20:42:31.798981 | ubuntu-bionic | ERROR: py36: could not install deps [-r/home/zuul/src/opendev.org/openstack/tripleo-ansible/test-requirements.txt, -r/home/zuul/src/opendev.org/openstack/tripleo-ansible/ansible-requirements.txt]; v = InvocationError('/home/zuul/src/opendev.org/openstack/tripleo-ansible/.tox/py36/bin/python3 -m pip install -c/home/zuul/src/opendev.org/openstack/requirements/upper-constraints.txt -c/home/zuul/src/opendev.org/openstack/tripleo-ansible/constraints.txt -r/home/zuul/src/opendev.org/openstack/tripleo-ansible/test-requirements.txt -r/home/zuul/src/opendev.org/openstack/tripleo-ansible/ansible-requirements.txt', 1)
2020-12-11 20:42:32.062210 | ubuntu-bionic | ERROR
2020-12-11 20:42:32.062613 | ubuntu-bionic | {
2020-12-11 20:42:32.062734 | ubuntu-bionic | "delta": "0:00:02.395810",
2020-12-11 20:42:32.062836 | ubuntu-bionic | "end": "2020-12-11 20:42:31.822816",
2020-12-11 20:42:32.062931 | ubuntu-bionic | "msg": "non-zero return code",
2020-12-11 20:42:32.063034 | ubuntu-bionic | "rc": 1,
2020-12-11 20:42:32.063151 | ubuntu-bionic | "start": "2020-12-11 20:42:29.427006"
2020-12-11 20:42:32.063253 | ubuntu-bionic | }

Revision history for this message
Rabi Mishra (rabi) wrote :

I think the issue is the use of links[1] in constraints with new pip version.

[1] https://github.com/openstack/tripleo-ansible/blob/master/constraints.txt

tags: added: alert ci
Changed in tripleo:
milestone: none → wallaby-rc1
tags: added: promotion-blocker
Revision history for this message
Alex Schultz (alex-schultz) wrote :
Changed in tripleo:
assignee: nobody → Alex Schultz (alex-schultz)
status: Triaged → In Progress
Changed in tripleo:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-ansible 2.1.0

This issue was fixed in the openstack/tripleo-ansible 2.1.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-ansible 3.0.0

This issue was fixed in the openstack/tripleo-ansible 3.0.0 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-ansible 1.5.2

This issue was fixed in the openstack/tripleo-ansible 1.5.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers