memcached logging is broken

Bug #1902922 reported by Michele Baldessari on 2020-11-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Michele Baldessari

Bug Description

This was first seen via https://bugzilla.redhat.com/show_bug.cgi?id=1891034

Even though we're setting memcached::logfile: '/var/log/memcached/memcached.log' there are no logs created in /var/log/containers/memcached.

The reason for this is that memcached::logfile in puppet-memcached simply adds a shell redirect to a file. The problem is that these are passed by tht and kolla to memcached as parameters and so are not read by the shell process and nothing gets redirected.

Changed in tripleo:
milestone: wallaby-1 → wallaby-2
Changed in tripleo:
milestone: wallaby-2 → wallaby-3
Changed in tripleo:
milestone: wallaby-3 → wallaby-rc1
Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers