[Ussuri + Master] Compute scale down regression

Bug #1889221 reported by Cédric Jeanneret on 2020-07-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Cédric Jeanneret

Bug Description

Hello,

A regression has been detected in the compute scale-down process:

"FATAL | Stop nova-compute healthcheck container | oc0-compute2 | error={"changed": false, "msg": "Could not find the requested service tripleo_nova_compute_healthcheck: host"}" while doint the scale-down with blacklisted thing (against master)

After some checks, it appears a scale task has been added in order to manage the nova_compute healthcheck systemd unit.
This is useless since Ussuri since we switched to podman native healthchecks.

Changed in tripleo:
status: Triaged → In Progress

Reviewed: https://review.opendev.org/743529
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=2b718135294b8d97a6114670b051690b2ea0c1a0
Submitter: Zuul
Branch: master

commit 2b718135294b8d97a6114670b051690b2ea0c1a0
Author: Cédric Jeanneret <email address hidden>
Date: Tue Jul 28 15:04:44 2020 +0200

    Do not manage healthcheck for nova-compute anymore

    Since we're using native podman healthcheck, we don't need to manage the
    systemd service anymore.

    Closes-Bug: #1889221

    Change-Id: Id5d693b6111f5906a99ffe4fec4befffc3940e23

Changed in tripleo:
status: In Progress → Fix Released

Reviewed: https://review.opendev.org/743863
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=8c6ada0d186b4229a949e03ce2841273de75ae2b
Submitter: Zuul
Branch: stable/ussuri

commit 8c6ada0d186b4229a949e03ce2841273de75ae2b
Author: Cédric Jeanneret <email address hidden>
Date: Tue Jul 28 15:04:44 2020 +0200

    Do not manage healthcheck for nova-compute anymore

    Since we're using native podman healthcheck, we don't need to manage the
    systemd service anymore.

    Closes-Bug: #1889221

    Change-Id: Id5d693b6111f5906a99ffe4fec4befffc3940e23
    (cherry picked from commit 2b718135294b8d97a6114670b051690b2ea0c1a0)

tags: added: in-stable-ussuri
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers