Ironic Conductor role need public endpoint create_swift_temp_url_key

Bug #1882545 reported by Harald Jensås on 2020-06-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Medium
Harald Jensås

Bug Description

2020-06-08 14:21:35.476131 | fa163e76-da91-3091-f547-00000000e024 | FATAL | Print the containers that failed to start | ironic-a-0 | error={"changed": false, "msg": "['create_swift_temp_url_key'] failed to start, check logs in
/var/log/containers/stdouts/"}

10.0.0.0/24 is the External network, the example IronicConductor roles does not have access to the External (public) network.
https://opendev.org/openstack/tripleo-heat-templates/src/branch/master/roles/IronicConductor.yaml#L8-L11

[root@ironic-a-0 stdouts]# cat create_swift_temp_url_key.log
2020-06-08T14:10:40.858238846+00:00 stdout F Check if a temporary URL key already exists
2020-06-08T14:12:55.512418657+00:00 stderr F Unable to establish connection to http://10.0.0.85:8080/v1/AUTH_7fafb7d4152c44b393547482d868114c: HTTPConnectionPool(host='10.0.0.85', port=8080): Max retries exceeded with url: /v1/AUTH_7fafb7d4152c44b393547482d868114c (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f17ff86d780>: Failed to establish a new connection: [Errno 110] Connection timed out',))
2020-06-08T14:12:55.727152780+00:00 stdout F Retrying...
2020-06-08T14:15:14.775655137+00:00 stderr F Unable to establish connection to http://10.0.0.85:8080/v1/AUTH_7fafb7d4152c44b393547482d868114c: HTTPConnectionPool(host='10.0.0.85', port=8080): Max retries exceeded with url: /v1/AUTH_7fafb7d4152c44b393547482d868114c (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f7fc5bf9780>: Failed to establish a new connection: [Errno 110] Connection timed out',))
2020-06-08T14:15:14.993464209+00:00 stdout F Retrying...
2020-06-08T14:17:34.042919927+00:00 stderr F Unable to establish connection to http://10.0.0.85:8080/v1/AUTH_7fafb7d4152c44b393547482d868114c: HTTPConnectionPool(host='10.0.0.85', port=8080): Max retries exceeded with url: /v1/AUTH_7fafb7d4152c44b393547482d868114c (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f7f38c92780>: Failed to establish a new connection: [Errno 110] Connection timed out',))
2020-06-08T14:17:34.275347143+00:00 stdout F Retrying...
2020-06-08T14:19:53.305454365+00:00 stderr F Unable to establish connection to http://10.0.0.85:8080/v1/AUTH_7fafb7d4152c44b393547482d868114c: HTTPConnectionPool(host='10.0.0.85', port=8080): Max retries exceeded with url: /v1/AUTH_7fafb7d4152c44b393547482d868114c (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f6783953780>: Failed to establish a new connection: [Errno 110] Connection timed out',))
2020-06-08T14:19:53.508704823+00:00 stdout F Retrying...
2020-06-08T14:22:12.567639129+00:00 stderr F Unable to establish connection to http://10.0.0.85:8080/v1/AUTH_7fafb7d4152c44b393547482d868114c: HTTPConnectionPool(host='10.0.0.85', port=8080): Max retries exceeded with url: /v1/AUTH_7fafb7d4152c44b393547482d868114c (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7fbcb27e4780>: Failed to establish a new connection: [Errno 110] Connection timed out',))
2020-06-08T14:22:12.782577568+00:00 stdout F Retrying...

We may want to set 'OS_INTERFACE=internal' so that the script use internal endpoint.
https://opendev.org/openstack/tripleo-heat-templates/src/branch/master/deployment/ironic/ironic-conductor-container-puppet.yaml#L511-L517

Changed in tripleo:
status: New → Triaged
milestone: none → victoria-1
importance: Undecided → Medium

Fix proposed to branch: master
Review: https://review.opendev.org/734138

Changed in tripleo:
assignee: nobody → Harald Jensås (harald-jensas)
status: Triaged → In Progress

Reviewed: https://review.opendev.org/734138
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=95563da90f2123a35427d7d6ffbb5663d0d6e514
Submitter: Zuul
Branch: master

commit 95563da90f2123a35427d7d6ffbb5663d0d6e514
Author: Harald Jensås <email address hidden>
Date: Mon Jun 8 17:02:34 2020 +0200

    Ironic create_swift_temp_url_key use internal edpoint

    Set OS_INTERFACE=internal in the container config script
    creating temporary URL's.

    Closes-Bug: #1882545
    Change-Id: Idb068b7ba2ca77babc3a019d5f60ca0cf7ebb2d6

Changed in tripleo:
status: In Progress → Fix Released

Reviewed: https://review.opendev.org/735114
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=1ba30cbb59831d3f6f6cde1bf75ccfb339cc8c01
Submitter: Zuul
Branch: stable/stein

commit 1ba30cbb59831d3f6f6cde1bf75ccfb339cc8c01
Author: Harald Jensås <email address hidden>
Date: Mon Jun 8 17:02:34 2020 +0200

    Ironic create_swift_temp_url_key use internal edpoint

    Set OS_INTERFACE=internal in the container config script
    creating temporary URL's.

    Closes-Bug: #1882545
    Change-Id: Idb068b7ba2ca77babc3a019d5f60ca0cf7ebb2d6
    (cherry picked from commit 95563da90f2123a35427d7d6ffbb5663d0d6e514)

tags: added: in-stable-stein

Reviewed: https://review.opendev.org/735113
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=20bb24a0edee1773a76e8071b38648dee8797ba4
Submitter: Zuul
Branch: stable/train

commit 20bb24a0edee1773a76e8071b38648dee8797ba4
Author: Harald Jensås <email address hidden>
Date: Mon Jun 8 17:02:34 2020 +0200

    Ironic create_swift_temp_url_key use internal edpoint

    Set OS_INTERFACE=internal in the container config script
    creating temporary URL's.

    Closes-Bug: #1882545
    Change-Id: Idb068b7ba2ca77babc3a019d5f60ca0cf7ebb2d6
    (cherry picked from commit 95563da90f2123a35427d7d6ffbb5663d0d6e514)

tags: added: in-stable-train

Reviewed: https://review.opendev.org/735112
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=faf2ae187f1476b2d33f26aec7816f574ea85023
Submitter: Zuul
Branch: stable/ussuri

commit faf2ae187f1476b2d33f26aec7816f574ea85023
Author: Harald Jensås <email address hidden>
Date: Mon Jun 8 17:02:34 2020 +0200

    Ironic create_swift_temp_url_key use internal edpoint

    Set OS_INTERFACE=internal in the container config script
    creating temporary URL's.

    Closes-Bug: #1882545
    Change-Id: Idb068b7ba2ca77babc3a019d5f60ca0cf7ebb2d6
    (cherry picked from commit 95563da90f2123a35427d7d6ffbb5663d0d6e514)

tags: added: in-stable-ussuri
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers