trailing centos-7 RT repository in centos-8 overcloud-full image

Bug #1881742 reported by Cédric Jeanneret on 2020-06-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Medium
Rafael Folco

Bug Description

Hello,

Since a few days I'm unable to deploy master TripleO overcloud due to this issue:

TASK [tripleo_bootstrap : Deploy network-scripts required for deprecated network service] ***
Tuesday 02 June 2020 08:08:24 +0000 (0:00:00.756) 0:00:19.100 **********
fatal: [overcloud-0-controller-0]: FAILED! => changed=false
  msg: Failed to download metadata for repo 'centos7-rt'
  rc: 1
  results: []
fatal: [overcloud-0-controller-1]: FAILED! => changed=false
  msg: Failed to download metadata for repo 'centos7-rt'
  rc: 1 results: []
fatal: [overcloud-0-controller-2]: FAILED! => changed=false
  msg: Failed to download metadata for repo 'centos7-rt'
  rc: 1
  results: []

After some digging, it appears the overcloud image has a centos7-rt repository, as set here:
https://github.com/openstack/tripleo-puppet-elements/blob/master/elements/overcloud-compute/pre-install.d/03-centos-rt

This is an issue, this repository shouldn't be present on a CentOS-8 image (or, at least, should be updated... ?)

Fix proposed to branch: master
Review: https://review.opendev.org/732618

Changed in tripleo:
assignee: Pooja Jadhav (poojajadhav22) → Rafael Folco (rafaelfolco)
status: Triaged → In Progress

Reviewed: https://review.opendev.org/732618
Committed: https://git.openstack.org/cgit/openstack/tripleo-puppet-elements/commit/?id=f14ac999fb3e724ab377ecc3792bffd151a9ef1c
Submitter: Zuul
Branch: master

commit f14ac999fb3e724ab377ecc3792bffd151a9ef1c
Author: Rafael Folco <email address hidden>
Date: Tue Jun 2 10:08:16 2020 -0300

    Remove centos7 RT repo from centos8 builds

    https://bugs.launchpad.net/tripleo/+bug/1881742

    Depends-On: https://review.opendev.org/#/c/730763

    Change-Id: Id2a75c8e5c4c3ea1b6954c8df2f619d6fd185260
    Closes-Bug: #1881742

Changed in tripleo:
status: In Progress → Fix Released

Reviewed: https://review.opendev.org/738154
Committed: https://git.openstack.org/cgit/openstack/tripleo-puppet-elements/commit/?id=4eca5b71cff8e00645ae338ac1125ec154024ddc
Submitter: Zuul
Branch: stable/ussuri

commit 4eca5b71cff8e00645ae338ac1125ec154024ddc
Author: Rafael Folco <email address hidden>
Date: Tue Jun 2 10:08:16 2020 -0300

    Remove centos7 RT repo from centos8 builds

    https://bugs.launchpad.net/tripleo/+bug/1881742

    Depends-On: https://review.opendev.org/#/c/730763

    Change-Id: Id2a75c8e5c4c3ea1b6954c8df2f619d6fd185260
    Closes-Bug: #1881742
    (cherry picked from commit f14ac999fb3e724ab377ecc3792bffd151a9ef1c)

tags: added: in-stable-ussuri

Reviewed: https://review.opendev.org/738729
Committed: https://git.openstack.org/cgit/openstack/tripleo-puppet-elements/commit/?id=432518a206c23988e733b0d966929648f3c6ff8d
Submitter: Zuul
Branch: stable/train

commit 432518a206c23988e733b0d966929648f3c6ff8d
Author: Rafael Folco <email address hidden>
Date: Tue Jun 2 10:08:16 2020 -0300

    Remove centos7 RT repo from centos8 builds

    https://bugs.launchpad.net/tripleo/+bug/1881742

    Depends-On: https://review.opendev.org/#/c/730763

    Change-Id: Id2a75c8e5c4c3ea1b6954c8df2f619d6fd185260
    Closes-Bug: #1881742
    (cherry picked from commit f14ac999fb3e724ab377ecc3792bffd151a9ef1c)
    (cherry picked from commit 4eca5b71cff8e00645ae338ac1125ec154024ddc)

tags: added: in-stable-train

Reviewed: https://review.opendev.org/738158
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart/commit/?id=59f6d3cb74fd94aa75677701757f50e9f1992c85
Submitter: Zuul
Branch: master

commit 59f6d3cb74fd94aa75677701757f50e9f1992c85
Author: yatinkarel <email address hidden>
Date: Fri Jun 26 13:27:15 2020 +0530

    Ignore failures in dnf when no repos are configured

    dnf config-manager --disable fails when no repos are
    configured. The issue is seen when centos7 repos is
    cleaned in CentOS8 with [1].

    [1] https://review.opendev.org/#/c/732618/

    Related-Bug: #1881742
    Change-Id: Ib4fbf430ed3a7f0ff5831986ec67c8fff7d0a69e

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers