Mistral introspection workflow does not detect manageable instances in large environments

Bug #1856031 reported by Piotr Kopec on 2019-12-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Piotr Kopec

Bug Description

Description
===========
When trying to introspect --all-manageable nodes the mistral workflow does not detect manageable nodes in large environemnts (~1000 nodes in this case). This is due to fact that there is limit when querying Ironic API for manageable nodes.

Steps to reproduce
==================
Run `openstack overcloud node introspect --all-manageable --provide` on large environment.

Expected result
===============
CMD above ends with info that there is no nodes in manageable state

Actual result
=============
Should start introspection.

Piotr Kopec (pkopec) on 2019-12-11
Changed in tripleo:
assignee: nobody → Piotr Kopec (pkopec)

Fix proposed to branch: master
Review: https://review.opendev.org/698469

Changed in tripleo:
status: New → In Progress
Changed in tripleo:
importance: Undecided → High
milestone: none → ussuri-1
tags: added: queens-backport-potential stein-backport-potential train-backport-potential

Reviewed: https://review.opendev.org/698469
Committed: https://git.openstack.org/cgit/openstack/tripleo-common/commit/?id=81145138adc2fbeda872debd2e17fe049c6fea0e
Submitter: Zuul
Branch: master

commit 81145138adc2fbeda872debd2e17fe049c6fea0e
Author: Piotr Kopec <email address hidden>
Date: Wed Dec 11 13:16:27 2019 +0100

    Using API instead yaql to get manageable nodes

    Currently tripleo.baremetal.v1 workbook is using YAQL to filter
    nodes in manageable state for introspection workflow. Since there
    is a way to get manageable nodes using client parameter [1] using
    YAQL is suboptimal.
    Moreover this does not work in large environments because default
    `limit` argument [2] does not list all nodes and nodes in manageable
    state might not detect in introspection.

    [1]: https://github.com/openstack/python-ironicclient/blob/master/ironicclient/v1/node.py#L75-L76
    [2]: https://github.com/openstack/python-ironicclient/blob/master/ironicclient/v1/node.py#L80-L87

    Change-Id: Id11adaa426487ed4f3ce4148c84f750cba1c0c11
    Closes-Bug: #1856031

Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers