[Stein] nova-placement fails to deploy due to bad config path

Bug #1853504 reported by Andrew Austin on 2019-11-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Undecided
Andrew Austin

Bug Description

Description
===========
https://review.opendev.org/#/c/688349/ includes a reference to /etc/placement rather than /etc/nova in the definition of the nova_placement_wait_for_service container. Since /etc/nova is still used in Stein, this causes the nova_placement_wait_for_service container to fail on a fresh Stein deployment.

Steps to reproduce
==================
* Attempt to deploy OpenStack Stein with THT that includes the above referenced backport
* Observe failure in nova_placement_wait_for_service due to missing configuration for nova-placement

Changed in tripleo:
assignee: nobody → Andrew Austin (marbindrakon)
Changed in tripleo:
status: New → In Progress

Reviewed: https://review.opendev.org/695555
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=07bb11f556a75137b9ee8a0700342d9f055a74b3
Submitter: Zuul
Branch: stable/stein

commit 07bb11f556a75137b9ee8a0700342d9f055a74b3
Author: Andrew Austin <email address hidden>
Date: Thu Nov 21 19:07:40 2019 +0000

    [Stein Only] Fix bad configuration path in nova-placement wait

    Change I6fcbc5cb5d4f3cbb618d9661d2a36c868e18b3d6 implements a wait for
    the nova-placement API to be available. The backport did not adjust the
    configuration path for nova-placement to be compatible with a Stein
    deployment. This patch sets the correct configuration path for Stein only.

    Closes-Bug: 1853504
    Related-Bug: 1842687
    Change-Id: Ibfaaa5b114dd07155d78f9d2d84a4c4a14c22ac8

tags: added: in-stable-stein

This issue was fixed in the openstack/tripleo-heat-templates 10.6.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers