[rocky only] tripleo-upgrade on rocky fails on lint

Bug #1853125 reported by Sofer Athlan-Guyot on 2019-11-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Sofer Athlan-Guyot

Bug Description

Hi,

this is the error:

2019-11-13 18:22:00.402610 | ubuntu-xenial | Errors:
2019-11-13 18:22:00.402823 | ubuntu-xenial | ansible-lint requires Python '>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*,!=3.5.*' but the running Python is 3.5.2
2019-11-13 18:22:00.402964 | ubuntu-xenial | You are using pip version 10.0.1, however version 19.3.1 is available.
2019-11-13 18:22:00.403107 | ubuntu-xenial | You should consider upgrading via the 'pip install --upgrade pip' command.

as seen there https://zuul.opendev.org/t/openstack/build/b6f96d86acb944a1ba28e8d569c2311c/log/job-output.txt

This is because of unsupported python 3.4 and 3.5 for ansible-lint (go and figure).

Now there are two ways to solve this either we change the ansible-lint version or we change the python version (3.6 would be fine ... !#@#?). I'm heading for ansible-lint because ... it's easier. If somebody know a way to change the python version instead...

I've check all the other version and we don't hit that combination so it doesn't fail, so rocky only.

Reviewed: https://review.opendev.org/694978
Committed: https://git.openstack.org/cgit/openstack/tripleo-upgrade/commit/?id=6162d6b884c9999547cf3cf7573810d5fc275e5b
Submitter: Zuul
Branch: stable/rocky

commit 6162d6b884c9999547cf3cf7573810d5fc275e5b
Author: Sofer Athlan-Guyot <email address hidden>
Date: Tue Nov 19 11:25:26 2019 +0100

    [rocky only] Change ansible-lint version to support py3.5.

    Change-Id: I82cf15f4adb09fdf21827b0e3ce9a9641ef9f619
    Closes-Bug: #1853125

tags: added: in-stable-rocky
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers