rdo mirror/proxy not working correctly

Bug #1846504 reported by wes hayutin on 2019-10-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
wes hayutin

Bug Description

[08:20:00] <weshay> apevec, jpena the rdo rhel8 proxy is busted in some way
[08:20:01] <weshay> http://mirror.regionone.rdo-cloud-tripleo.rdoproject.org:8080/rdo/rhel8-master/current-tripleo/delorean.repo
[08:20:08] <weshay> is an old hash
[08:20:30] <weshay> apevec, jpena doesn't match https://trunk.rdoproject.org/rhel8-master/current-tripleo/delorean.repo
[08:20:46] <apevec> weshay, it was suggested to fetch hash directly, not via mirror
[08:21:22] <apevec> hmm, I'm getting Error code: SSL_ERROR_RX_RECORD_TOO_LONG on that mirror url
[08:22:24] <apevec> and in curl: (35) error:1408F10B:SSL routines:ssl3_get_record:wrong version number
[08:22:40] <apevec> ok, http: works
[08:23:27] <apevec> weshay, I got now the same content via curl
[08:23:30] <jpena> weshay: I get the same on both
[08:23:43] <apevec> yeah, catch expired
[08:23:45] <jpena> there is a cache ttl
[08:23:59] <apevec> weshay, either way, let's fetch hash directly

Was pulling
fd46c80632bbd7abc8411277bfc4819f6b95a485_bf6d0acd/delorean.repo

where it should have been pulling

968c9526ff2eeafaa13207a791f61173db604fff_9e598812

will put in changes to not use the rdo proxy as suggested.

Fix proposed to branch: master
Review: https://review.opendev.org/686430

Changed in tripleo:
status: Triaged → In Progress
Changed in tripleo:
milestone: train-rc1 → ussuri-1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers