validate docker image in tripleo-upgrade is not working with podman.

Bug #1843023 reported by Sofer Athlan-Guyot on 2019-09-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Sofer Athlan-Guyot

Bug Description

Hi,

that validation script [1] is totally wired to docker and is not working with podman.

Simply changing docker to podman is not enough to get it right as the output has slightly changed as well.

[1] https://github.com/openstack/tripleo-upgrade/blob/master/templates/validate_docker_images_versions.sh.j2

Changed in tripleo:
assignee: nobody → Jose Luis Franco (jfrancoa)
Changed in tripleo:
assignee: Jose Luis Franco (jfrancoa) → Sofer Athlan-Guyot (sofer-athlan-guyot)

Fix proposed to branch: master
Review: https://review.opendev.org/681263

Changed in tripleo:
status: Confirmed → In Progress

Reviewed: https://review.opendev.org/681263
Committed: https://git.openstack.org/cgit/openstack/tripleo-upgrade/commit/?id=5aa1aee425880f46c9844afab144a6c829145340
Submitter: Zuul
Branch: master

commit 5aa1aee425880f46c9844afab144a6c829145340
Author: Sofer Athlan-Guyot <email address hidden>
Date: Tue Sep 10 15:29:11 2019 +0200

    Fix container validation after overcloud update.

    The current validation script is tuned to docker. We switch to podman
    and adjust the expected output.

    Change-Id: I06949a8b63dba58761e901584c1e49b4f63d2356
    Closes-Bug: #1843023

Changed in tripleo:
status: In Progress → Fix Released

Change abandoned by Emilien Macchi (<email address hidden>) on branch: stable/stein
Review: https://review.opendev.org/681511
Reason: We are facing gate issue: https://bugs.launchpad.net/tripleo/+bug/1844446

To clear the gate we need to abandon this patch and I will restore once the gate is ready again to land patches in TripleO. Please don't touch this patch, and ask on #tripleo Wes or Emilien for any question. Thanks for your patience.

Change abandoned by wes hayutin (<email address hidden>) on branch: master
Review: https://review.opendev.org/682854
Reason: gate freeze :) sorry.. sent you an email

Reviewed: https://review.opendev.org/682854
Committed: https://git.openstack.org/cgit/openstack/tripleo-upgrade/commit/?id=cece0f85d471114b07d4d5082e841fc97b7a59af
Submitter: Zuul
Branch: master

commit cece0f85d471114b07d4d5082e841fc97b7a59af
Author: Sofer Athlan-Guyot <email address hidden>
Date: Wed Sep 18 12:14:53 2019 +0200

    Fix image validation when AP services get several images.

    When AP (Actif/Passif) service get several images back from the host
    the script is broken because it wrongly tests any left over image.

    We fix that by sorting them by tag (the higher being at bottom of the
    list) and taking only the last one.

    We ensure as well that re-running the script doesn't unnecessarily
    increase the number of hosts we test for AP services.

    Change-Id: I24e05a15975fb5a696d195d87257bc7b7e1c561b
    Related-Bug: #1843023

Reviewed: https://review.opendev.org/681511
Committed: https://git.openstack.org/cgit/openstack/tripleo-upgrade/commit/?id=1c2309761315b41432c52295593e7ed9e30f0411
Submitter: Zuul
Branch: stable/stein

commit 1c2309761315b41432c52295593e7ed9e30f0411
Author: Sofer Athlan-Guyot <email address hidden>
Date: Tue Sep 10 15:29:11 2019 +0200

    Fix container validation after overcloud update.

    The current validation script is tuned to docker. We switch to podman
    and adjust the expected output.

    Change-Id: I06949a8b63dba58761e901584c1e49b4f63d2356
    Closes-Bug: #1843023
    (cherry picked from commit 5aa1aee425880f46c9844afab144a6c829145340)

tags: added: in-stable-stein

Reviewed: https://review.opendev.org/683066
Committed: https://git.openstack.org/cgit/openstack/tripleo-upgrade/commit/?id=67f82ef005c816acd759037ae1257ddb7e292686
Submitter: Zuul
Branch: stable/stein

commit 67f82ef005c816acd759037ae1257ddb7e292686
Author: Sofer Athlan-Guyot <email address hidden>
Date: Wed Sep 18 12:14:53 2019 +0200

    Fix image validation when AP services get several images.

    When AP (Actif/Passif) service get several images back from the host
    the script is broken because it wrongly tests any left over image.

    We fix that by sorting them by tag (the higher being at bottom of the
    list) and taking only the last one.

    We ensure as well that re-running the script doesn't unnecessarily
    increase the number of hosts we test for AP services.

    Change-Id: I24e05a15975fb5a696d195d87257bc7b7e1c561b
    Related-Bug: #1843023
    (cherry picked from commit cece0f85d471114b07d4d5082e841fc97b7a59af)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers