net.ifnames is disabled by default under rhel8

Bug #1841441 reported by Alex Schultz on 2019-08-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Low
Alex Schultz

Bug Description

net.ifnames is set to 0 in the /etc/default/grub under rhel 8. This can make it hard to generate configurations for os-net-config and sriov deployments. Let's explicitly enable net.ifnames when we build the overcloud images to ensure a consistent naming scheme.

Fix proposed to branch: master
Review: https://review.opendev.org/678581

Changed in tripleo:
assignee: nobody → Alex Schultz (alex-schultz)

Reviewed: https://review.opendev.org/678581
Committed: https://git.openstack.org/cgit/openstack/tripleo-image-elements/commit/?id=8da8d9a51b287d520c465fae254262fc4286e92e
Submitter: Zuul
Branch: master

commit 8da8d9a51b287d520c465fae254262fc4286e92e
Author: Alex Schultz <email address hidden>
Date: Mon Aug 26 08:49:44 2019 -0600

    Clear net.ifnames definition

    With RHEL8, net.ifnames is set to 0 in the grub config. This is a change
    in the default image which can have user impacts. We want to clear it to
    go back to the previously defined behavior in RHEL7.

    Change-Id: I621066ea5e0e934668ff4c91e991a95d18e019f7
    Closes-Bug: #1841441

Changed in tripleo:
status: In Progress → Fix Released

Reviewed: https://review.opendev.org/679169
Committed: https://git.openstack.org/cgit/openstack/tripleo-image-elements/commit/?id=1ebd7afac1c49b9fe413a286c21c311bb0a31072
Submitter: Zuul
Branch: stable/stein

commit 1ebd7afac1c49b9fe413a286c21c311bb0a31072
Author: Alex Schultz <email address hidden>
Date: Mon Aug 26 08:49:44 2019 -0600

    Clear net.ifnames definition

    With RHEL8, net.ifnames is set to 0 in the grub config. This is a change
    in the default image which can have user impacts. We want to clear it to
    go back to the previously defined behavior in RHEL7.

    Change-Id: I621066ea5e0e934668ff4c91e991a95d18e019f7
    Closes-Bug: #1841441
    (cherry picked from commit 8da8d9a51b287d520c465fae254262fc4286e92e)

tags: added: in-stable-stein

This issue was fixed in the openstack/tripleo-image-elements 10.4.2 release.

This issue was fixed in the openstack/tripleo-image-elements 10.5.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers