rspec-puppet-facts 1.9.5 requires Ruby version >= 2.1.0

Bug #1838376 reported by Martin Schuppert on 2019-07-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Alex Schultz

Bug Description

puppet-openstack-unit-4.8-centos-7 fails in e.g. [1] (queens) due to newer rspec-puppet-facts
version which requires Ruby version >= 2.1.0:

From http://logs.openstack.org/69/672469/1/gate/puppet-openstack-unit-4.8-centos-7/61fa927/ :

2019-07-29 18:15:16.858442 | centos-7 | Fetching rspec-puppet-facts 1.9.5
2019-07-29 18:15:16.942305 | centos-7 | Installing rspec-puppet-facts 1.9.5
2019-07-29 18:15:17.003749 | centos-7 | Gem::InstallError: rspec-puppet-facts requires Ruby version >= 2.1.0.
2019-07-29 18:15:17.004086 | centos-7 | An error occurred while installing rspec-puppet-facts (1.9.5), and Bundler
2019-07-29 18:15:17.004196 | centos-7 | cannot continue.
2019-07-29 18:15:17.004421 | centos-7 | Make sure that `gem install rspec-puppet-facts -v '1.9.5' --source
2019-07-29 18:15:17.004603 | centos-7 | 'https://rubygems.org/'` succeeds before bundling.
2019-07-29 18:15:17.004666 | centos-7 |
2019-07-29 18:15:17.004753 | centos-7 | In Gemfile:
2019-07-29 18:15:17.005005 | centos-7 | puppet-openstack_spec_helper was resolved to 12.0.0, which depends on
2019-07-29 18:15:17.005126 | centos-7 | rspec-puppet-facts
2019-07-29 18:15:17.527751 | centos-7 | bundler: failed to load command: rake (/home/zuul/workspace/.bundled_gems/bin/rake)
2019-07-29 18:15:17.528476 | centos-7 | Bundler::GitError: The git source https://git.openstack.org/openstack/puppet-openstack_spec_helper is not yet checked out. Please run `bundle install` before trying to start your application
2019-07-29 18:15:17.528856 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/source/git/git_proxy.rb:235:in `allowed_in_path'
2019-07-29 18:15:17.529275 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/source/git/git_proxy.rb:192:in `find_local_revision'
2019-07-29 18:15:17.529610 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/source/git/git_proxy.rb:64:in `revision'
2019-07-29 18:15:17.529956 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/source/git.rb:225:in `revision'
2019-07-29 18:15:17.530307 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/source/git.rb:93:in `install_path'
2019-07-29 18:15:17.530638 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/source/path.rb:126:in `expanded_path'
2019-07-29 18:15:17.531002 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/source/path.rb:163:in `load_spec_files'
2019-07-29 18:15:17.531322 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/source/git.rb:200:in `load_spec_files'
2019-07-29 18:15:17.531665 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/source/path.rb:100:in `local_specs'
2019-07-29 18:15:17.532004 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/source/git.rb:167:in `specs'
2019-07-29 18:15:17.532381 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/definition.rb:758:in `block in converge_locked_specs'
2019-07-29 18:15:17.532687 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/definition.rb:744:in `each'
2019-07-29 18:15:17.533067 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/definition.rb:744:in `converge_locked_specs'
2019-07-29 18:15:17.533388 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/definition.rb:247:in `resolve'
2019-07-29 18:15:17.533686 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/definition.rb:170:in `specs'
2019-07-29 18:15:17.534026 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/definition.rb:237:in `specs_for'
2019-07-29 18:15:17.534367 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/definition.rb:226:in `requested_specs'
2019-07-29 18:15:17.534710 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/runtime.rb:108:in `block in definition_method'
2019-07-29 18:15:17.534995 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/runtime.rb:20:in `setup'
2019-07-29 18:15:17.535241 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler.rb:107:in `setup'
2019-07-29 18:15:17.535518 | centos-7 | /home/zuul/workspace/.bundled_gems/gems/bundler-1.17.3/lib/bundler/setup.rb:20:in `<top (required)>'
2019-07-29 18:15:17.535743 | centos-7 | /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
2019-07-29 18:15:17.535992 | centos-7 | /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in `require'
2019-07-29 18:15:17.772974 | centos-7 | ERROR
2019-07-29 18:15:17.773591 | centos-7 | {
2019-07-29 18:15:17.773764 | centos-7 | "delta": "0:02:24.891689",
2019-07-29 18:15:17.773924 | centos-7 | "end": "2019-07-29 18:15:17.537683",
2019-07-29 18:15:17.774080 | centos-7 | "msg": "non-zero return code",
2019-07-29 18:15:17.774231 | centos-7 | "rc": 1,
2019-07-29 18:15:17.774382 | centos-7 | "start": "2019-07-29 18:12:52.645994"
2019-07-29 18:15:17.774532 | centos-7 | }

[1] https://review.opendev.org/#/c/672469/

Changed in tripleo:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Alex Schultz (alex-schultz)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers