Octavia amphora certificate files in wrong path and with invalid content

Bug #1830190 reported by Carlos Goncalves on 2019-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Carlos Goncalves

Bug Description

Octavia amphora certificate files are being created in an unexpected path and with invalid content
[root@controller-2 log]# ls /var/lib/config-data/puppet-generated/ | grep octavia
octavia
octaviaca_cert_path
octaviaca_private_key_path
octaviaclient_cert_path
octavia.md5sum

[root@controller-2 log]# cat /var/lib/config-data/puppet-generated/octaviaca_cert_path
ca_cert_content[root@controller-2 log]# cat /var/lib/config-data/puppet-generated/octaviaca_private_key_path
private_key_content[root@controller-2 log]# cat /var/lib/config-data/puppet-generated/octaviaclient_cert_path
service_pem_content[root@controller-2 log]#

Steps to Reproduce:
1. Deploy TripleO Stein with Octavia enabled
2. Create amphora load balancer

Actual results:
Load balancer will not be created successfully. It will go into ERROR provisioning_status

Expected results:
Amphora load balancer would be successfully provisioned and go ACTIVE.

Originally reported at https://bugzilla.redhat.com/show_bug.cgi?id=1713289

Fix proposed to branch: master
Review: https://review.opendev.org/660971

Changed in tripleo:
assignee: nobody → Carlos Goncalves (cgoncalves)
status: New → In Progress
Changed in tripleo:
milestone: none → train-1
importance: Undecided → High
tags: added: stein-backport-potential

Reviewed: https://review.opendev.org/660971
Committed: https://git.openstack.org/cgit/openstack/tripleo-common/commit/?id=4de9f78b291e2a1f0311aa4c705daba08322cc7e
Submitter: Zuul
Branch: master

commit 4de9f78b291e2a1f0311aa4c705daba08322cc7e
Author: Carlos Goncalves <email address hidden>
Date: Thu May 23 12:25:52 2019 +0200

    Fix Octavia certificate file path and content

    Certificate files were being created in a wrong path and with invalid
    content. The bug was caused because Ansible variables were not being
    quoted, and as so Ansible assumed plain text instead.

    Closes-Bug: #1830190

    Change-Id: Ie576537d77b57927d430f20b274d1cb5d351241e

Changed in tripleo:
status: In Progress → Fix Released

Reviewed: https://review.opendev.org/661352
Committed: https://git.openstack.org/cgit/openstack/tripleo-common/commit/?id=71c099f2092e77b35099eee1e1e763283549c7ad
Submitter: Zuul
Branch: stable/stein

commit 71c099f2092e77b35099eee1e1e763283549c7ad
Author: Carlos Goncalves <email address hidden>
Date: Thu May 23 12:25:52 2019 +0200

    Fix Octavia certificate file path and content

    Certificate files were being created in a wrong path and with invalid
    content. The bug was caused because Ansible variables were not being
    quoted, and as so Ansible assumed plain text instead.

    Closes-Bug: #1830190

    Change-Id: Ie576537d77b57927d430f20b274d1cb5d351241e
    (cherry picked from commit 4de9f78b291e2a1f0311aa4c705daba08322cc7e)

tags: added: in-stable-stein

This issue was fixed in the openstack/tripleo-common 11.0.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers