periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset010-master times out during deploy: Mistral client fails to initialize base action

Bug #1820045 reported by Gabriele Cerami on 2019-03-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mistral
Undecided
Unassigned
tripleo
Critical
Sagi (Sergey) Shnaidman

Bug Description

logs at

https://logs.rdoproject.org/openstack-periodic/git.openstack.org/openstack-infra/tripleo-ci/master/periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset010-master/9ee209e/job-output.txt.gz#_2019-03-13_02_41_44_512183

shows that the deployment fails for a timeout

Yatin Karel analyzed logs and found that at

https://logs.rdoproject.org/openstack-periodic/git.openstack.org/openstack-infra/tripleo-ci/master/periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset010-master/9ee209e/logs/undercloud/var/log/extra/errors.txt.txt.gz#_2019-03-13_00_30_51_476

mistral fails with the error:

2019-03-13 00:30:51.476 ERROR /var/log/containers/mistral/executor.log.1: 8 ERROR mistral.executors.default_executor Traceback (most recent call last):
2019-03-13 00:30:51.476 ERROR /var/log/containers/mistral/executor.log.1: 8 ERROR mistral.executors.default_executor File "/usr/lib/python2.7/site-packages/mistral/executors/default_executor.py", line 114, in run_action
2019-03-13 00:30:51.476 ERROR /var/log/containers/mistral/executor.log.1: 8 ERROR mistral.executors.default_executor result = action.run(action_ctx)
2019-03-13 00:30:51.476 ERROR /var/log/containers/mistral/executor.log.1: 8 ERROR mistral.executors.default_executor File "/usr/lib/python2.7/site-packages/mistral/actions/openstack/base.py", line 130, in run
2019-03-13 00:30:51.476 ERROR /var/log/containers/mistral/executor.log.1: 8 ERROR mistral.executors.default_executor (self.__class__.__name__, self.client_method_name, str(e))
2019-03-13 00:30:51.476 ERROR /var/log/containers/mistral/executor.log.1: 8 ERROR mistral.executors.default_executor ActionException: MistralAction.executions.find failed: _list() takes at least 2 arguments (1 given)
2019-03-13 00:30:51.476 ERROR /var/log/containers/mistral/executor.log.1: 8 ERROR mistral.executors.default_executor

which may be caused by a recent review at

 https://review.openstack.org/554950

affects: tripleo → mistral
Changed in mistral:
milestone: stein-rc1 → none
affects: mistral → tripleo
Changed in tripleo:
milestone: none → stein-rc1
Changed in tripleo:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/643304
Committed: https://git.openstack.org/cgit/openstack/python-mistralclient/commit/?id=0cd6b282920214d2995d1203aa0ad7d33c825b10
Submitter: Zuul
Branch: master

commit 0cd6b282920214d2995d1203aa0ad7d33c825b10
Author: Sagi Shnaidman <email address hidden>
Date: Thu Mar 14 13:52:53 2019 +0200

    Fix typo for self.list

    Mistake was introduced in https://review.openstack.org/#/c/554950
    Added an abstract method list to the base ResourceManager that
    raises a notImplementedError if called (instead of using
    abc.abstractmethod that would force the implementation of a list
    method that might not be required for all resources)

    Closes-Bug: #1820045

    Change-Id: I0c69e1beeb452a95cc5988a462f733806afbfafc

Changed in mistral:
status: New → Fix Released
yatin (yatinkarel) wrote :

Until mistralclient is released with the Fix, we have included the commit in rdo:- https://review.rdoproject.org/r/#/c/19435/, jobs are now running with the mistralclient fix.

wes hayutin (weshayutin) wrote :

fixed!

Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers