tripleo-modify-image dev install broken (fails to install pip)

Bug #1816775 reported by Dan Prince on 2019-02-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Dan Prince

Bug Description

Tried to use the -dev mod installer today and it fails to install the python-pip RPM using RDO containers.

Dan Prince (dan-prince) on 2019-02-20
Changed in tripleo:
importance: Undecided → High
assignee: nobody → Dan Prince (dan-prince)
milestone: none → stein-3
status: New → Triaged

Fix proposed to branch: master
Review: https://review.openstack.org/638174

Changed in tripleo:
status: Triaged → In Progress

Reviewed: https://review.openstack.org/638174
Committed: https://git.openstack.org/cgit/openstack/ansible-role-tripleo-modify-image/commit/?id=8f0c6bf141da1740c47188737b95f347af8b69cf
Submitter: Zuul
Branch: master

commit 8f0c6bf141da1740c47188737b95f347af8b69cf
Author: Dan Prince <email address hidden>
Date: Wed Feb 20 09:33:36 2019 -0500

    Fix dev install (yum -y...)

    Fixes an issue in 410408ef1b665aab4672d4b3dad2bbc7de543b7d where
    we removed the -y options for the pip RPM install. This functionally
    broke the dev mode playbook unless you had manually installed pip
    in the container (not normally the case for RDO images).

    Change-Id: Ic96d9eb708bff763cbe4395cf7770b5239879309
    Closes-bug: #1816775

Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers