dmidecode >= 3.1 lower cases the system uuid which breaks folks who defined per node customization with upper case uuids

Bug #1816652 reported by Alex Schultz on 2019-02-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Alex Schultz

Bug Description

dmidecode >= 3.1 has normalized uuids to be lower case. The problem is that they may have been uppercase prior to this.

https://github.com/mirror/dmidecode/blob/master/NEWS#L2

This means anywhere we are using system UUIDs must be cause insensitive (handle both upper/lower). We currently use this in several places like in the per-node hieradata customizations and the os-net-config mappings file. This had previously broken ceph ansible in Bug 1814070

Anyone who does a minor update from CentOS7.5 with per-node customization to CentOS7.6 will have their per-node customization broken.

Changed in tripleo:
assignee: nobody → Alex Schultz (alex-schultz)

Fix proposed to branch: master
Review: https://review.openstack.org/637984

Changed in tripleo:
status: Triaged → In Progress
tags: added: queens-backport-potential
tags: added: rocky-backport-potential

Reviewed: https://review.openstack.org/637984
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=e2a8a494c5abf64ac5ed16e7f2b20edd4535c2d4
Submitter: Zuul
Branch: master

commit e2a8a494c5abf64ac5ed16e7f2b20edd4535c2d4
Author: Alex Schultz <email address hidden>
Date: Tue Feb 19 12:50:16 2019 -0700

    Handle upper and lower case system uuids

    We need to be able to handle when system uuids are upper or lower case
    because newer versions of dmidecode have normalized to lower case. Users
    who were on CentOS/RHEL 7.5 and older may have per-node customizations
    with upper case which turn lowercase with an update to 7.6. This affects
    hieradata customizations as well as os-net-config mapping files. This
    change outputs both an upper and lowercase hieradata uuid file to handle
    the both versions of the UUID. Additionally this change normalizes the
    id comparison for os-net-config mappings to lower case.

    Change-Id: I65f46056f8a908c60c99d1cee3738344a0bce6b7
    Closes-Bug: #1816652

Changed in tripleo:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/638494
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=b87f6a257c6c8c46081d9cdcc63f921e7e1f43c2
Submitter: Zuul
Branch: stable/queens

commit b87f6a257c6c8c46081d9cdcc63f921e7e1f43c2
Author: Alex Schultz <email address hidden>
Date: Tue Feb 19 12:50:16 2019 -0700

    Handle upper and lower case system uuids

    We need to be able to handle when system uuids are upper or lower case
    because newer versions of dmidecode have normalized to lower case. Users
    who were on CentOS/RHEL 7.5 and older may have per-node customizations
    with upper case which turn lowercase with an update to 7.6. This affects
    hieradata customizations as well as os-net-config mapping files. This
    change outputs both an upper and lowercase hieradata uuid file to handle
    the both versions of the UUID. Additionally this change normalizes the
    id comparison for os-net-config mappings to lower case.

    Conflicts:
     puppet/extraconfig/pre_deploy/per_node.yaml

    Change-Id: I65f46056f8a908c60c99d1cee3738344a0bce6b7
    Closes-Bug: #1816652
    (cherry picked from commit e2a8a494c5abf64ac5ed16e7f2b20edd4535c2d4)

tags: added: in-stable-queens

Reviewed: https://review.openstack.org/638491
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=759b711b9457a5827cf75e8dcb36e3ca905dec1c
Submitter: Zuul
Branch: stable/rocky

commit 759b711b9457a5827cf75e8dcb36e3ca905dec1c
Author: Alex Schultz <email address hidden>
Date: Tue Feb 19 12:50:16 2019 -0700

    Handle upper and lower case system uuids

    We need to be able to handle when system uuids are upper or lower case
    because newer versions of dmidecode have normalized to lower case. Users
    who were on CentOS/RHEL 7.5 and older may have per-node customizations
    with upper case which turn lowercase with an update to 7.6. This affects
    hieradata customizations as well as os-net-config mapping files. This
    change outputs both an upper and lowercase hieradata uuid file to handle
    the both versions of the UUID. Additionally this change normalizes the
    id comparison for os-net-config mappings to lower case.

    Change-Id: I65f46056f8a908c60c99d1cee3738344a0bce6b7
    Closes-Bug: #1816652
    (cherry picked from commit e2a8a494c5abf64ac5ed16e7f2b20edd4535c2d4)

tags: added: in-stable-rocky

This issue was fixed in the openstack/tripleo-heat-templates 10.4.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers