[fs16] multinode periodic job runned in check overcloud deploy got failed Could not fetch contents for file:///tmp/tripleoclient-j2egNX/tripleo-heat-templates/deployment/metrics/collectd-container-puppet.yaml

Bug #1816553 reported by chandan kumar on 2019-02-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Unassigned

Bug Description

In order to unblock CI, we were testing fs016 periodic jobs using following depends on
Depends-On: https://review.openstack.org/604311
Depends-On: https://review.openstack.org/#/c/637679/
Depends-On: https://review.openstack.org/#/c/637482/

in order to check telemetry tests failure. It will use the promotion hash from periodic pipeline.

Fs16 periodic multinode job failed while deploying overcloud:
https://logs.rdoproject.org/49/18749/9/check/periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset016-master/3af2474/logs/undercloud/home/zuul/overcloud_deploy.log.txt.gz#_2019-02-19_10_33_04

2019-02-19 10:33:04 | Exception occured while running the command
2019-02-19 10:33:04 | Traceback (most recent call last):
2019-02-19 10:33:04 | File "/usr/lib/python2.7/site-packages/tripleoclient/command.py", line 29, in run
2019-02-19 10:33:04 | super(Command, self).run(parsed_args)
2019-02-19 10:33:04 | File "/usr/lib/python2.7/site-packages/osc_lib/command/command.py", line 41, in run
2019-02-19 10:33:04 | return super(Command, self).run(parsed_args)
2019-02-19 10:33:04 | File "/usr/lib/python2.7/site-packages/cliff/command.py", line 184, in run
2019-02-19 10:33:04 | return_code = self.take_action(parsed_args) or 0
2019-02-19 10:33:04 | File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 906, in take_action
2019-02-19 10:33:04 | self._deploy_tripleo_heat_templates_tmpdir(stack, parsed_args)
2019-02-19 10:33:04 | File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 365, in _deploy_tripleo_heat_templates_tmpdir
2019-02-19 10:33:04 | new_tht_root, tht_root)
2019-02-19 10:33:04 | File "/usr/lib/python2.7/site-packages/tripleoclient/v1/overcloud_deploy.py", line 441, in _deploy_tripleo_heat_templates
2019-02-19 10:33:04 | cleanup=(not parsed_args.no_cleanup))
2019-02-19 10:33:04 | File "/usr/lib/python2.7/site-packages/tripleoclient/utils.py", line 994, in process_multiple_environments
2019-02-19 10:33:04 | env_path=f.name)
2019-02-19 10:33:04 | File "/usr/lib/python2.7/site-packages/heatclient/common/template_utils.py", line 319, in process_environment_and_files
2019-02-19 10:33:04 | env_base_url)
2019-02-19 10:33:04 | File "/usr/lib/python2.7/site-packages/heatclient/common/template_utils.py", line 357, in resolve_environment_urls
2019-02-19 10:33:04 | is_object=is_object, object_request=object_request)
2019-02-19 10:33:04 | File "/usr/lib/python2.7/site-packages/heatclient/common/template_utils.py", line 161, in get_file_contents
2019-02-19 10:33:04 | file_content = utils.read_url_content(str_url)
2019-02-19 10:33:04 | File "/usr/lib/python2.7/site-packages/heatclient/common/utils.py", line 417, in read_url_content
2019-02-19 10:33:04 | raise exc.CommandError(_('Could not fetch contents for %s') % url)
2019-02-19 10:33:04 | CommandError: Could not fetch contents for file:///tmp/tripleoclient-j2egNX/tripleo-heat-templates/deployment/metrics/collectd-container-puppet.yaml
2019-02-19 10:33:04 | Could not fetch contents for file:///tmp/tripleoclient-j2egNX/tripleo-heat-templates/deployment/metrics/collectd-container-puppet.yaml
2019-02-19 10:33:04 | END return value: 1
2019-02-19 10:33:04 | Removing the current plan files
2019-02-19 10:33:04 | Uploading new plan files
2019-02-19 10:33:04 | Plan updated.
2019-02-19 10:33:04 | Processing templates in the directory /tmp/tripleoclient-j2egNX/tripleo-heat-templates
2019-02-19 10:33:04 | + status_code=1
2019-02-19 10:33:04 | + openstack stack list
2019-02-19 10:33:04 | + grep -q overcloud

https://review.openstack.org/#/c/636507/ -> flatten qdrouterd service configs caused it.

https://review.openstack.org/#/c/636232/ will fix it.

summary: - [fs16] multinode periodic job runned in check got failed Could not fetch
- contents for file:///tmp/tripleoclient-j2egNX/tripleo-heat-
- templates/deployment/metrics/collectd-container-puppet.yaml
+ [fs16] multinode periodic job runned in check overcloud deploy got
+ failed Could not fetch contents for file:///tmp/tripleoclient-j2egNX
+ /tripleo-heat-templates/deployment/metrics/collectd-container-
+ puppet.yaml
wes hayutin (weshayutin) on 2019-02-19
Changed in tripleo:
status: Confirmed → Triaged
Quique Llorente (quiquell) wrote :

We have to investigate why standalone is passing here https://review.openstack.org/#/c/636507/

Changed in tripleo:
status: Triaged → In Progress
Quique Llorente (quiquell) wrote :

Standalone passed because collectd path was ok at ci/environment/scenario003-standalone.yaml

Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers