stable/rocky undercloud install fails on duplicate declaration of systemctl-daemon-reload

Bug #1816477 reported by Alex Schultz on 2019-02-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Alex Schultz

Bug Description

http://logs.openstack.org/73/636873/3/gate/tripleo-ci-centos-7-undercloud-oooq/c47c5a3/logs/undercloud/home/zuul/undercloud_install.log.txt.gz#_2019-02-18_17_44_06

2019-02-18 17:44:06 | 2019-02-18 17:44:06,780 INFO: Error: Evaluation Error: Error while evaluating a Resource Statement, Evaluation Error: Error while evaluating a Resource Statement, Duplicate declaration: Exec[systemctl-daemon-reload] is already declared in file /etc/puppet/manifests/puppet-stack-config.pp:99; cannot redeclare at /etc/puppet/modules/systemd/manifests/systemctl/daemon_reload.pp:5 at /etc/puppet/modules/systemd/manifests/systemctl/daemon_reload.pp:5:3 at /etc/puppet/modules/rabbitmq/manifests/config.pp:231 on node centos-7-inap-mtl01-0002682802

Caused by a bump in puppet-rabbitmq https://review.rdoproject.org/r/#/c/18878/

Alex Schultz (alex-schultz) wrote :
Changed in tripleo:
assignee: nobody → Alex Schultz (alex-schultz)
status: Triaged → In Progress
Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers