rabbitmq does not get restarted on config changes

Bug #1816070 reported by Michele Baldessari on 2019-02-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Michele Baldessari

Bug Description

The following code:
          rabbitmq_restart_bundle:
            start_order: 0
            config_volume: rabbitmq
            detach: false
            net: host
            ipc: host
            user: root
            command:
              - '/usr/bin/bootstrap_host_exec'
              - 'rabbitmq'
              - str_replace:
                  template:
                    'if /usr/sbin/pcs resource show rabbitmq-bundle; then /usr/sbin/pcs resource restart --wait=PCMKTIMEOUT rabbitmq-bundle; echo "rabbitmq-bundle restart invoked"; fi'
                  params:
                    PCMKTIMEOUT: {get_param: PcmkConfigRestartTimeout}

will be triggered if the config changes for the rabbitmq container and so it should trigger a restart.
The problem is that it will never trigger because the call to 'bootstrap_host_exec rabbitmq' will always do nothing because rabbitmq now is calles oslo_messaging_*

Changed in tripleo:
status: Triaged → In Progress
tags: added: idempotency

Reviewed: https://review.openstack.org/623337
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=d59ac1bd9a36a96a2c1e287fca0b2c347c543955
Submitter: Zuul
Branch: master

commit d59ac1bd9a36a96a2c1e287fca0b2c347c543955
Author: Michele Baldessari <email address hidden>
Date: Mon Feb 11 10:56:25 2019 +0100

    Fix rabbitmq restart

    With the move to pluggable messaging, we call the services to restart
    differently and not always just 'rabbitmq' any longer.

    Closes-Bug: #1816070

    Change-Id: I9bc7603dbb073d735390db398c0e00c75cebd6fa

Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/tripleo-heat-templates 10.4.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers