[Fedora 28] [standalone]'NoneType' object is not iterable while generating template

Bug #1814516 reported by chandan kumar on 2019-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
chandan kumar

Bug Description

On Fedora 28, https://review.openstack.org/#/c/634644/, we are seeing an unrelated failure on fedora 28 standalone job while deploying standalone job.

http://logs.openstack.org/44/634644/2/check/tripleo-ci-fedora-28-standalone/59273e0/logs/undercloud/home/zuul/standalone_deploy.log.txt.gz#_2019-02-04_09_11_41

2019-02-04 09:11:41 | ** Handling template files **
2019-02-04 09:11:41 | Traceback (most recent call last):
2019-02-04 09:11:41 | File "/usr/share/openstack-tripleo-heat-templates/tools/process-templates.py", line 349, in <module>
2019-02-04 09:11:41 | network_data_path, (not opts.safe), opts.dry_run)
2019-02-04 09:11:41 | File "/usr/share/openstack-tripleo-heat-templates/tools/process-templates.py", line 131, in process_templates
2019-02-04 09:11:41 | for n in network_data:
2019-02-04 09:11:41 | TypeError: 'NoneType' object is not iterable
2019-02-04 09:11:41 | Problems generating templates.
2019-02-04 09:11:41 | Exception: Problems generating templates.
2019-02-04 09:11:41 | Traceback (most recent call last):
2019-02-04 09:11:41 | File "/usr/lib/python3.6/site-packages/tripleoclient/v1/tripleo_deploy.py", line 1216, in _standalone_deploy
2019-02-04 09:11:41 | parsed_args)
2019-02-04 09:11:41 | File "/usr/lib/python3.6/site-packages/tripleoclient/v1/tripleo_deploy.py", line 747, in _deploy_tripleo_heat_templates
2019-02-04 09:11:41 | roles_file_path, networks_file_path, parsed_args)
2019-02-04 09:11:41 | File "/usr/lib/python3.6/site-packages/tripleoclient/v1/tripleo_deploy.py", line 641, in _setup_heat_environments
2019-02-04 09:11:41 | raise exceptions.DeploymentError(msg)
2019-02-04 09:11:41 | tripleoclient.exceptions.DeploymentError: Problems generating templates.
2019-02-04 09:11:41 | None
2019-02-04 09:11:42 | Not cleaning working directory /home/zuul/tripleo-heat-installer-templates
2019-02-04 09:11:42 | Not cleaning ansible directory /home/zuul/undercloud-ansible-7wuvuku9
2019-02-04 09:11:42 | Install artifact is located at /home/zuul/undercloud-install-20190204091141.tar.bzip2

Might be there is some problem with the templates needs to be fixed.

Fix proposed to branch: master
Review: https://review.openstack.org/634661

Changed in tripleo:
assignee: nobody → chandan kumar (chkumar246)
status: Triaged → In Progress
Quique Llorente (quiquell) wrote :

The weird thing is that it's deployting and old THT rpm

openstack-tripleo-heat-templates-10.3.1-0.20190114043412.0873bd8.fc28.noarch

Latest from DLRN is

openstack-tripleo-heat-templates-10.3.1-0.20190204081448.7b9c549.el7.noarch.rpm

And this has the fix on it.

Quique Llorente (quiquell) wrote :

Silly me this is fedora damnit

chandan kumar (chkumar246) wrote :

openstack-tripleo-heat-templates-10.3.1-0.20190114043412.0873bd8.fc28.noarch is used which is older one.

chandan kumar (chkumar246) wrote :

From here http://logs.openstack.org/11/604311/8/check/tripleo-ci-fedora-28-standalone/be654f4/logs/undercloud/var/log/extra/package-list-installed.txt.gz

openstack-tripleo-heat-templates.noarch
                                10.3.1-0.20190114043412.0873bd8.fc28
                                                           @delorean is getting installed from delorean not from delorean-current.

Quique Llorente (quiquell) wrote :

After updateing it manually at my reproducer I get
ast metadata expiration check: 0:59:36 ago on Mon Feb 4 11:24:53 2019.
Dependencies resolved.

 Problem: cannot install the best update candidate for package openstack-tripleo-heat-templates-10.3.1-0.20190114043412.0873bd8.fc28.noarch
  - nothing provides ansible-role-atos-hsm needed by openstack-tripleo-heat-templates-10.3.1-0.20190204045335.7b9c549.fc28.noarch
======================================================================================================================

So

nsible-role-atos-hsm is the issue

chandan kumar (chkumar246) wrote :

03:07:15 quiquell|rover │ At my reproducer I have this after doing a sudo dnf update -y
03:07:33 quiquell|rover │ ast metadata expiration check: 0:59:36 ago on Mon Feb 4 11:24:53 2019.
03:07:34 quiquell|rover │ Dependencies resolved.
03:07:36 quiquell|rover │ Problem: cannot install the best update candidate for package
                         │ openstack-tripleo-heat-templates-10.3.1-0.20190114043412.0873bd8.fc28.noarch
03:07:38 quiquell|rover │ - nothing provides ansible-role-atos-hsm needed by
                         │ openstack-tripleo-heat-templates-10.3.1-0.20190204045335.7b9c549.fc28.noarch
03:07:40 quiquell|rover │ ====================================================================================
                         │ ==================================
03:07:42 quiquell|rover │ Pa

Needs a new promotion in order to get it fixed

Quique Llorente (quiquell) wrote :

Looks like this RPM is at newer promotions, so we need a f28 promotion :-/

Change abandoned by Chandan Kumar (<email address hidden>) on branch: master
Review: https://review.openstack.org/634661
Reason: Not needed, can fixed by new promotion

Quique Llorente (quiquell) wrote :

Ok promoted
{
  "commit_hash": "bf97151ce15feccd98be3b43c06656939841eb9b",
  "distro_hash": "8fb61313282a3bdc542bc7c190ff47fd1d68f9c6",
  "promote_name": "current-tripleo",
  "repo_hash": "bf97151ce15feccd98be3b43c06656939841eb9b_8fb61313",
  "repo_url": "https://trunk.rdoproject.org/fedora/bf/97/bf97151ce15feccd98be3b43c06656939841eb9b_8fb61313",
  "timestamp": 1549287254,
}

Let's see if it works now.

Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers