grpc-1.18.0-x86_64-linux requires ruby version >= 2.2, which is incompatible

Bug #1812105 reported by wes hayutin on 2019-01-16
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tripleo
Critical
Alex Schultz

Bug Description

2019-01-16 20:11:20.956920 | centos-7 | Fetching https://git.openstack.org/openstack/puppet-openstack_spec_helper
2019-01-16 20:11:28.807847 | centos-7 | Fetching gem metadata from https://rubygems.org/........
2019-01-16 20:11:30.460711 | centos-7 | Resolving dependencies.......
2019-01-16 20:11:30.616503 | centos-7 | grpc-1.18.0-x86_64-linux requires ruby version >= 2.2, which is incompatible
2019-01-16 20:11:30.616634 | centos-7 | with the current version, ruby 2.0.0p648
2019-01-16 20:11:30.891249 | centos-7 | bundler: command not found: rake
2019-01-16 20:11:30.891433 | centos-7 | Install missing gem executables with `bundle install`
2019-01-16 20:11:32.047266 | centos-7 | ERROR
2019-01-16 20:11:32.047737 | centos-7 | {
2019-01-16 20:11:32.047852 | centos-7 | "delta": "0:00:13.301044",
2019-01-16 20:11:32.047959 | centos-7 | "end": "2019-01-16 20:11:30.899600",
2019-01-16 20:11:32.048062 | centos-7 | "msg": "non-zero return code",
2019-01-16 20:11:32.048164 | centos-7 | "rc": 127,
2019-01-16 20:11:32.048271 | centos-7 | "start": "2019-01-16 20:11:17.598556"
2019-01-16 20:11:32.050577 | centos-7 | }
2019-01-16 20:11:32.214178 |

http://logs.openstack.org/50/630250/2/gate/puppet-openstack-unit-4.8-centos-7/34e151a/job-output.txt.gz#_2019-01-16_20_11_20_956920

wes hayutin (weshayutin) on 2019-01-16
tags: added: alert
Alex Schultz (alex-schultz) wrote :
Changed in tripleo:
assignee: nobody → Alex Schultz (alex-schultz)
wes hayutin (weshayutin) on 2019-01-16
Changed in tripleo:
status: Triaged → In Progress
Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers