standalone_upgrade CI job not applying patch under test

Bug #1811371 reported by Jose Luis Franco on 2019-01-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tripleo
High
Jose Luis Franco

Bug Description

Like whe can see in this patch https://review.openstack.org/#/c/628161/11/
a set of new upgrade tasks are being added, one of them named: "Stop MySQL server and ensure redo log is cleaned up before upgrade". But when we look for it in the standalone_upgrade.log, we can't see it: http://logs.openstack.org/61/628161/11/check/tripleo-ci-centos-7-standalone-upgrade/be73524/logs/undercloud/home/zuul/standalone_upgrade.log.txt.gz , neither in the tripleo-heat-installer-templates directory: http://logs.openstack.org/61/628161/11/check/tripleo-ci-centos-7-standalone-upgrade/be73524/logs/undercloud/home/zuul/tripleo-heat-installer-templates/docker/services/database/mysql.yaml.txt.gz but the package seems to be build with the patch applied when checking the job logs.

The issue seems to be caused by https://github.com/openstack/tripleo-quickstart-extras/commit/05b5b272f38217ce09bc0e9a4a484f97bffcd2e2#diff-3214758135904ff969021b2459a0781c patch, as it removes the "yum update" which would install the new package defined in the built repository. This problem doesn't occur for the undercloud-upgrade job, because the package is being updated in the undercloud_upgrade.sh script: http://logs.openstack.org/61/628161/11/check/tripleo-ci-centos-7-containerized-undercloud-upgrades/028d897/logs/undercloud/home/zuul/undercloud_upgrade.sh.txt.gz

Tags: ci Edit Tag help
summary: - standalone_upgrade jCI ob not applying patch under test
+ standalone_upgrade CI job not applying patch under test

Fix proposed to branch: master
Review: https://review.openstack.org/630228

Changed in tripleo:
assignee: nobody → Jose Luis Franco (jfrancoa)
status: Triaged → In Progress
Changed in tripleo:
milestone: stein-2 → stein-3

Reviewed: https://review.openstack.org/630228
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart-extras/commit/?id=0a9346dd9cd452494970dd45fd53603d66d169a5
Submitter: Zuul
Branch: master

commit 0a9346dd9cd452494970dd45fd53603d66d169a5
Author: Jose Luis Franco Arza <email address hidden>
Date: Fri Jan 11 14:46:38 2019 +0100

    Update tht,tripleoclient and tc before standalone_upgrade.

    In a similar way it's being done during undercloud upgrade
    [0] we need to update certain packages before executing the
    standalone environment upgrade. These packages are
    python-tripleoclient, tripleo-heat-templates and tripleo-common.

    [0] - https://docs.openstack.org/tripleo-docs/latest/upgrade/undercloud.html
    Closes-Bug: #1811371
    Change-Id: Iac96f7196ffa0304ca36816c18fc348e27a6ea02

Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers