Compute node failing with Designate enabled

Bug #1811134 reported by Ben Nemec on 2019-01-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Ben Nemec

Bug Description

I just tried to deploy Designate locally on a two node virt environment and the compute node failed configuration. I'm not sure why this just started happening, but it looks like the problem is that we're including the neutron::designate class in the base neutron manifest, when in reality it only needs to be in neutron-server (the service that actually uses those settings). Including it for neutron-ovs-agent on the compute node causes configuration to fail because that node doesn't have the necessary designate hieradata.

I've already tested a fix locally and will push it for review in a moment.

Fix proposed to branch: master
Review: https://review.openstack.org/629645

Changed in tripleo:
status: Triaged → In Progress
Changed in tripleo:
milestone: stein-2 → stein-3

Reviewed: https://review.openstack.org/629645
Committed: https://git.openstack.org/cgit/openstack/puppet-tripleo/commit/?id=d0b4ecde5c440226ea97977cbe19f1a94912bcc9
Submitter: Zuul
Branch: master

commit d0b4ecde5c440226ea97977cbe19f1a94912bcc9
Author: Ben Nemec <email address hidden>
Date: Wed Jan 9 19:14:05 2019 +0000

    Only include neutron::designate class in neutron server

    The only service that needs the neutron::designate configuration
    options is neutron-server, and if we include it for other neutron
    services we may end up with missing config because the relevant
    designate hieradata is only generated for neutron-api.

    Change-Id: I2c71132a1c3be34b51e81b0932f094cfacadd5aa
    Closes-Bug: 1811134

Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/puppet-tripleo 10.3.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers