[promotion job][master][FS030][OVN] Tempest test failing with No IPv4 addresses found in: <port dict>

Bug #1810706 reported by yatin on 2019-01-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tripleo
Critical
Unassigned

Bug Description

Tempest test(tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_network_basic_ops) is failing in Featureset030 promotion job with below Traceback:-

AssertionError: [] is not true : No IPv4 addresses found in: [{u'allowed_address_pairs': [], u'extra_dhcp_opts': [], u'updated_at': u'2019-01-02T14:24:00Z', u'device_owner': u'compute:nova', u'revision_number': 6, u'port_security_enabled': True, u'binding:profile': {}, u'fixed_ips': [{u'subnet_id': u'bcca0a17-a1b0-4d96-85a1-92c3cef3b116', u'ip_address': u'10.100.0.3'}], u'id': u'f500790c-a6fe-4bad-a13b-afec707072dc', u'security_groups': [u'a83d7c2a-3094-49b2-9354-50a670218bca'], u'binding:vif_details': {u'port_filter': True}, u'binding:vif_type': u'ovs', u'mac_address': u'fa:16:3e:59:68:85', u'project_id': u'5fe5e0639eb34f149646245080ccb5ad', u'status': u'DOWN', u'binding:host_id': u'upstream-centos-7-rdo-cloud-0000377217.localdomain', u'description': u'', u'tags': [], u'qos_policy_id': None, u'resource_request': None, u'name': u'', u'admin_state_up': True, u'network_id': u'fb4f7d93-8bc6-4774-9cef-8a68fe114bec', u'tenant_id': u'5fe5e0639eb34f149646245080ccb5ad', u'created_at': u'2019-01-02T14:23:49Z', u'binding:vnic_type': u'normal', u'device_id': u'e7e3ce78-d0cf-446c-ab4e-6099c54db665'}]

Reason:- No 'ACTIVE' port ^^ as per http://git.openstack.org/cgit/openstack/tempest/tree/tempest/scenario/manager.py#n845

Example log:-
https://logs.rdoproject.org/openstack-periodic/git.openstack.org/openstack-infra/tripleo-ci/master/periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset030-master/7518d58/logs/undercloud/home/zuul/tempest.log.txt.gz#_2019-01-02_14_24_16

It's failing since 2nd January:-
https://review.rdoproject.org/zuul/builds?job_name=periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset030-master

Following neutron patch seems causing it:- https://review.openstack.org/#/c/590363/

yatin (yatinkarel) on 2019-01-07
tags: added: promotion-blocker
wes hayutin (weshayutin) on 2019-01-07
Changed in tripleo:
milestone: none → stein-2
status: New → Triaged
importance: Undecided → Critical
Changed in tripleo:
milestone: stein-2 → stein-3
Daniel Alvarez (dalvarezs) wrote :

We have a fix up in tempest waiting for reviews: https://review.openstack.org/449695

However, the root cause of this issue is this os-vif change:
https://github.com/openstack/os-vif/commit/165ed325917e5deadb274ad9c122db157c0b55b2#diff-024723487bc761f5ba9d39bbf77f7721

Numan was proposing to revert this change in os-vif as it causes unnecessary transitions of the vif port

Arx Cruz (arxcruz) on 2019-01-30
Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers