tempest run failed with 'The specified regex doesn't match with anything ' on tripleo-ci-centos-7-scenario001-multinode-oooq-container

Bug #1803547 reported by chandan kumar on 2018-11-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
chandan kumar

Bug Description

tripleo-ci-centos-7-scenario001-multinode-oooq-container job failed twice in check/gate jobs when tempest is runned from container.

http://logs.openstack.org/13/617913/2/check/tripleo-ci-centos-7-scenario001-multinode-oooq-container/e232a20/logs/undercloud/home/zuul/tempest.log.txt.gz#_2018-11-15_11_43_21

2018-11-15 11:43:08 | | barbican_tests | barbican_tempest_plugin.plugin:BarbicanTempestPlugin |
2018-11-15 11:43:08 | +--------------------------------+-----------------------------------------------------------------+
2018-11-15 11:43:21 | The specified regex doesn't match with anything

http://logs.openstack.org/06/604706/32/gate/tripleo-ci-centos-7-scenario001-multinode-oooq-container/b338e21/logs/undercloud/home/zuul/tempest.log.txt.gz#_2018-11-15_03_53_53

there might be something wrong happening while loading tempest tests, It needs investigation.

Changed in tripleo:
assignee: nobody → chandan kumar (chkumar246)
wes hayutin (weshayutin) on 2018-11-15
Changed in tripleo:
milestone: none → stein-2

Fix proposed to branch: master
Review: https://review.openstack.org/618209

Changed in tripleo:
status: Triaged → In Progress

Fix proposed to branch: master
Review: https://review.openstack.org/618477

chandan kumar (chkumar246) wrote :

So here is the issue,
currently in tripleo-ci-centos-7-scenario001-multinode-oooq-container resembles to fs016
where are running tempest_whitelist_new:
  - 'tempest.scenario.test_volume_boot_pattern.TestVolumeBootPattern.test_volume_boot_pattern'
- 'telemetry_tempest_plugin.scenario.test_telemetry_integration.TestTelemetryIntegration'
tests, but these both tests are in master skip list
https://github.com/openstack/tripleo-quickstart-extras/blob/master/roles/validate-tempest/vars/tempest_skip_master.yml#L60 and https://github.com/openstack/tripleo-quickstart-extras/blob/master/roles/validate-tempest/vars/tempest_skip_master.yml#L132 so these two tests will be ignored by tempest then tempest has no tests to run which is leading to the above error.

Best solution is to add a some basic test be default in the validate-tempest role so that we have some sanity if all are in blacklist. It will solve the problem

Change abandoned by Chandan Kumar (<email address hidden>) on branch: master
Review: https://review.openstack.org/618209

Changed in tripleo:
assignee: chandan kumar (chkumar246) → Sorin Sbarnea (ssbarnea)
Sorin Sbarnea (ssbarnea) on 2018-11-17
Changed in tripleo:
assignee: Sorin Sbarnea (ssbarnea) → chandan kumar (chkumar246)

Change abandoned by Chandan Kumar (<email address hidden>) on branch: master
Review: https://review.openstack.org/618477
Reason: not needed

yatin (yatinkarel) wrote :

Affecting fs016 in master promotion job and rdoinfo gating job:- https://logs.rdoproject.org/openstack-periodic/git.openstack.org/openstack-infra/tripleo-ci/master/periodic-tripleo-ci-centos-7-multinode-1ctlr-featureset016-master/2f255ba/logs/undercloud/home/zuul/tempest.log.txt.gz

Also it's good to fix the original issue as technically there is no real test running in this featureset. Adding promotion-blocker tag.

tags: added: promotion-blocker

Reviewed: https://review.openstack.org/618674
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart/commit/?id=a774b91930325cda596b1e99e4943563ec17a6a3
Submitter: Zuul
Branch: master

commit a774b91930325cda596b1e99e4943563ec17a6a3
Author: Chandan Kumar <email address hidden>
Date: Mon Nov 19 10:44:31 2018 +0530

    Run tempest.api.identity.v3 tests in fs016

    This review adds identity.v3 (keystone) to fs16 tempest whitelist.
    The TestVolumeBootPattern [1] and TestTelemetryIntegration[2] are skipped
    in the master skip list meaning no tests are executed for fs16
    leading to the bug below.

    [1.] https://review.openstack.org/617845
    [2.] https://review.openstack.org/#/c/604091/

    Closes-Bug:#1803547

    Change-Id: Id441fccc97c6ee7e53a9a0c22df1395b4b6368e5

Changed in tripleo:
status: In Progress → Fix Released

This issue was fixed in the openstack/tripleo-quickstart 2.1.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers