unable to find user root: no matching entries in passwd file

Bug #1803544 reported by Cédric Jeanneret on 2018-11-15
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
tripleo
Critical
Unassigned

Bug Description

We sometime hit the following issue while deploying an undercloud:

2018-11-13 18:16:19 | "2018-11-13 18:13:39,017 ERROR: 4514 -- Failed running docker-puppet.py for heat_api",
2018-11-13 18:16:19 | "2018-11-13 18:13:39,018 ERROR: 4514 -- error mounting image volumes: unable to find user root: no matching entries in passwd file",

Problem is: it's not always the case, and it's not always the same container. Until now, I had it for swift-related and heat-related containers.

It's happening for a while, at random:
http://logstash.openstack.org/#/dashboard/file/logstash.json?query=message:%5C%22no%20matching%20entries%20in%20passwd%20file%5C%22

tags: removed: tripleo-heat-templates
tags: added: ci
Rabi Mishra (rabi) wrote :

Possibly a runc issue as there is some discussion[1] about something similar in a docker thread[1] which ends with:

"Currently there is no resolution to this issue. It is being tracked via an internal bug.”

And that's not good:/

[1] https://forums.docker.com/t/unable-to-find-user-root-no-matching-entries-in-passwd-file/26545

Marios Andreou (marios-b) wrote :

just seen this on the master tht gate check centos standalone http://logs.openstack.org/98/604298/105/check/tripleo-ci-centos-7-standalone/5b9e669/logs/undercloud/home/zuul/standalone_deploy.log.txt.gz#_2018-11-29_20_50_50

 2018-11-29 20:50:50 | "2018-11-29 20:48:29,700 ERROR: 20487 -- error mounting image volumes: unable to find user root: no matching entries in passwd file",

Sorin Sbarnea (ssbarnea) wrote :

We are seeing more and more of these errors and they seems to be caused by "classified" docker bug.

http://status.openstack.org/elastic-recheck/index.html#1803544

https://forums.docker.com/t/unable-to-find-user-root-no-matching-entries-in-passwd-file/26545/7

What can we do about it?

wes hayutin (weshayutin) wrote :

This is happening a lot and failing the gate, I see it's being worked on but setting alert for visibility.

Changed in tripleo:
importance: High → Critical
wes hayutin (weshayutin) on 2018-12-11
tags: removed: alert

Change abandoned by Emilien Macchi (<email address hidden>) on branch: master
Review: https://review.openstack.org/624420

Sorin Sbarnea (ssbarnea) wrote :

The fix is supposed to land before the end of the week. I am sure that Emilien with post a comment when this lands.

Change abandoned by Emilien Macchi (<email address hidden>) on branch: master
Review: https://review.openstack.org/624420

wes hayutin (weshayutin) wrote :

Bug 1803544 - unable to find user root: no matching entries in passwd file
0 fails in 24 hrs / 0 fails in 10 days
Projects: (tripleo - Triaged)
No matches
Logstash Launchpad

wes hayutin (weshayutin) wrote :

closing.

Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.