chrony setup is ignoring NtpServer by default

Bug #1802538 reported by Alex Schultz
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
Alex Schultz

Bug Description

The chrony configuration is not properly honoring NtpServer if that is configured because NtpPool is configured by default. This is a regression from previous versions when NtpServer was *the* way to configure ntp servers. We should not ignore the NtpServer.

Revision history for this message
Alex Schultz (alex-schultz) wrote :

Hmm we have code to restart chronyd so maybe not. It seems the config file wasn't being updated for some reason. Looking into it

summary: - chrony setup does not restart chrony to update the config if it is
- already running
+ chrony setup is ignoring NtpServer by default
description: updated
Changed in tripleo:
importance: Medium → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to tripleo-heat-templates (master)

Fix proposed to branch: master
Review: https://review.openstack.org/617001

Changed in tripleo:
status: Triaged → In Progress
description: updated
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to ansible-role-chrony (master)

Fix proposed to branch: master
Review: https://review.openstack.org/617007

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to ansible-role-chrony (master)

Reviewed: https://review.openstack.org/617007
Committed: https://git.openstack.org/cgit/openstack/ansible-role-chrony/commit/?id=9baecd0573ba7b853b526250dd8967504197dcdb
Submitter: Zuul
Branch: master

commit 9baecd0573ba7b853b526250dd8967504197dcdb
Author: Alex Schultz <email address hidden>
Date: Fri Nov 9 11:19:57 2018 -0700

    Move default values to defaults

    The os specific variables are overriding the provided vars so we should
    only define things that should not be overridable because they are OS
    specific (service names, config file locations, etc)

    Change-Id: I2af49137d91c34eeb68353d7438a5ee09c8166c9
    Closes-Bug: #1802538

Changed in tripleo:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to tripleo-heat-templates (master)

Reviewed: https://review.openstack.org/617001
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=92285fdbfe7363b4e39d4f284e9773be8e5ee51e
Submitter: Zuul
Branch: master

commit 92285fdbfe7363b4e39d4f284e9773be8e5ee51e
Author: Alex Schultz <email address hidden>
Date: Fri Nov 9 10:45:29 2018 -0700

    Do not ignore NtpServer by default

    Before we had the NtpPool option which has been added because of chrony,
    the NtpServer parameter was the way to configure the ntp sources for
    TripleO. We should not ignore them because this can break people coming
    from previous versions.

    Change-Id: I09c08740a3bd9b64950430496fecdae903bb6ebc
    Closes-Bug: #1802538

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to tripleo-heat-templates (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/618568

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to tripleo-heat-templates (master)

Reviewed: https://review.openstack.org/618568
Committed: https://git.openstack.org/cgit/openstack/tripleo-heat-templates/commit/?id=31cd46f8881170918c9ef0af59614ac2c0e84d23
Submitter: Zuul
Branch: master

commit 31cd46f8881170918c9ef0af59614ac2c0e84d23
Author: Alex Schultz <email address hidden>
Date: Fri Nov 16 10:18:26 2018 -0700

    Ensure chrony is restarted

    If chrony is already running, we need to make sure that we restart it if
    necessary before waiting for the time syncs.

    Change-Id: Ic3c7917a4edff46a77d48c07cd77a936f8e63a58
    Related-Bug: #1802538

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/tripleo-heat-templates 10.2.0

This issue was fixed in the openstack/tripleo-heat-templates 10.2.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers