Undercloud install fails at Unknown function: 'normalize_ip_for_uri'

Bug #1802083 reported by Quique Llorente on 2018-11-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Sagi (Sergey) Shnaidman

Bug Description

http://logs.openstack.org/79/615479/18/check/tripleo-ci-centos-7-containers-multinode/4b2c753/logs/undercloud/home/zuul/install-undercloud.log.txt.gz#_2018-11-07_08_36_01_071
2018-11-07 08:36:01.070 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "2018-11-07 08:33:35,299 INFO: 8117 -- Removing container: docker-puppet-zaqar",
2018-11-07 08:36:01.070 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "2018-11-07 08:33:36,129 INFO: 8117 -- Pulling image: 192.168.24.1:8787/tripleomaster/centos-binary-zaqar:current-tripleo-updated-20181107074616",
2018-11-07 08:36:01.070 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "2018-11-07 08:33:48,983 ERROR: 8115 -- Failed running docker-puppet.py for ironic_api",
2018-11-07 08:36:01.070 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "2018-11-07 08:33:48,983 ERROR: 8115 -- Notice: hiera(): Cannot load backend module_data: cannot load such file -- hiera/backend/module_data_backend",
2018-11-07 08:36:01.071 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "2018-11-07 08:33:48,983 ERROR: 8115 -- + mkdir -p /etc/puppet",
2018-11-07 08:36:01.071 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "+ '[' -n file,file_line,concat,augeas,cron,ironic_config ']'",
2018-11-07 08:36:01.071 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "+ TAGS='--tags file,file_line,concat,augeas,cron,ironic_config'",
2018-11-07 08:36:01.071 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "+ origin_of_time=/var/lib/config-data/ironic_api.origin_of_time",
2018-11-07 08:36:01.071 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "+ touch /var/lib/config-data/ironic_api.origin_of_time",
2018-11-07 08:36:01.071 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "+ /usr/bin/puppet apply --summarize --detailed-exitcodes --color=false --logdest syslog --logdest console --modulepath=/etc/puppet/modules:/usr/share/openstack-puppet/modules --tags file,file_line,concat,augeas,cron,ironic_config /etc/config.pp",
2018-11-07 08:36:01.072 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "Error: Evaluation Error: Unknown function: 'os_transport_url'. at /etc/puppet/modules/tripleo/manifests/profile/base/ironic.pp:75:36 on node undercloud.localdomain",
2018-11-07 08:36:01.072 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "2018-11-07 08:33:48,983 INFO: 8115 -- Finished processing puppet configs for ironic_api",
2018-11-07 08:36:01.072 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "2018-11-07 08:33:48,984 INFO: 8115 -- Starting configuration of nova using image 192.168.24.1:8787/tripleomaster/centos-binary-nova-api:current-tripleo-updated-20181107074616",
2018-11-07 08:36:01.072 16249 WARNING tripleoclient.v1.tripleo_deploy.Deploy [ ] "2018-11-07 08:33:49,297 INFO: 8115 -- Removing container: docker-puppet-nova",

Possibe root cause, functions moving to a new place at puppet openstacklib
http://git.openstack.org/cgit/openstack/puppet-openstacklib/commit/?id=fd3156bc60ec537ffc53aea1d0e0035c9fe17638

Quique Llorente (quiquell) wrote :
wes hayutin (weshayutin) on 2018-11-07
Changed in tripleo:
status: Confirmed → Triaged
Cédric Jeanneret (cjeanner) wrote :

Revert has been merged.

Emilien Macchi (emilienm) wrote :

Removing alert, since revert merged.

tags: removed: alert

Reviewed: https://review.openstack.org/616188
Committed: https://git.openstack.org/cgit/openstack/puppet-tripleo/commit/?id=8315b01f3392ad66ec788ecc30a9cc80340fb939
Submitter: Zuul
Branch: master

commit 8315b01f3392ad66ec788ecc30a9cc80340fb939
Author: Tobias Urdin <email address hidden>
Date: Wed Nov 7 13:50:17 2018 +0100

    Add openstacklib to requirements in metadata.json

    There is a constraints in (atleast) Puppet 5 that to
    use new ruby api functions the module must have a requirement
    for the module that serves those functions.

    Testing to add it here to resolve the openstacklib unknown function
    bug that was introduced.

    This constraints was dropped in Puppet 6.0.0.

    Change-Id: Ie0c4c719befe854422ec1893f4f2dcba36fa7777
    Related-Bug: 1802083

This issue was fixed in the openstack/puppet-openstacklib 14.1.0 release.

Changed in tripleo:
milestone: stein-2 → stein-3
Changed in tripleo:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers