reproducer script installs wrong puppet-tripleo package from delorian-current instead of the gating repo built locally

Bug #1800495 reported by Bogdan Dobrelya on 2018-10-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
High
wes hayutin

Bug Description

I tried to reproduce https://review.openstack.org/#/c/609947/ with http://logs.openstack.org/47/609947/10/check/tripleo-ci-centos-7-undercloud-containers/8c2a2e1/logs/reproducer-quickstart.sh, on my libvirt env.

It deployed fine, but the puppet-tripleo package was installed from delorean-current instead of the gating repo built locally and containing the wanted ZUUL_CHANGES under test.

$ yum list puppet-tripleo
Installed Packages
puppet-tripleo.noarch 10.1.0-0.20181029060757.fcadda0.el7 @delorean-current

$ ls /opt/gating_repo/puppet*.rpm
/opt/gating_repo/puppet-tripleo-10.0.1-0.20181029133342.e57abb8.el7.noarch.rpm

$ cat /etc/yum.repos.d/gating.repo
[gating-repo]
name=Gating repository
baseurl=file:///opt/gating_repo
enabled=1
gpgcheck=0
priority=1

$ cat /etc/yum.repos.d/delorean-current.repo
[delorean-current]
name=delorean-current
baseurl=http://mirror.regionone.rdo-cloud.rdoproject.org:8080/rdo/centos7/6a/87/6a87e5bbd785a92562f6c58a10a278b038167a2d_9e598812
gpgcheck=0
enabled=1
priority=10
includepkgs=ansible-role-container-registry,ansible-role-tripleo*,ansible-tripleo-ipsec,instack,instack-undercloud,openstack-tripleo-*,os-apply-config,os-collect-config,os-net-config,os-refresh-config,puppet-*,python*-tripleo*,python*-paunch*

description: updated
description: updated
Changed in tripleo:
importance: Undecided → Medium
milestone: none → stein-1
status: New → Triaged
tags: added: ci quickstart
Bogdan Dobrelya (bogdando) wrote :

may be packages related rebasing issue, put it back to new

Changed in tripleo:
status: Triaged → Incomplete
status: Incomplete → New

your code is not rebased and then delorean-current has a higher version and installed instead of your patch, afaiu
although we have a rebasing, but I think it doesn't work with "depends-on" in the patch: https://github.com/openstack/tripleo-quickstart-extras/blob/master/roles/nodepool-setup/tasks/patch_repos.yml#L32
need to check why

Changed in tripleo:
importance: Medium → High
Changed in tripleo:
milestone: stein-1 → stein-2
Changed in tripleo:
status: New → Triaged
milestone: stein-2 → stein-3
wes hayutin (weshayutin) wrote :

Let's follow up on this...

wes hayutin (weshayutin) wrote :

zuul@centos-7-rdo-cloud-0000000000 ~]$ rpm -q puppet-tripleo
puppet-tripleo-10.2.1-0.20190215185432.8253d88.el7.noarch

Feb 19 22:00:00 Updated: puppet-tripleo-10.2.1-0.20190219215918.62e47e1.el7.noarch

yumdownload test
=========================
puppet-tripleo-10.2.1-0.20190215185432.8253d88.el7.noarch.rpm
[zuul@centos-7-rdo-cloud-0000000000 ~]$ ^C
[zuul@centos-7-rdo-cloud-0000000000 ~]$ yumdownloader puppet-tripleo
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
124 packages excluded due to repository priority protections
puppet-tripleo-10.2.1-0.20190219215918.62e47e1.el7.noarch.rpm

Fixed in http://logs.openstack.org/35/624335/15/check/tripleo-ci-centos-7-undercloud-containers/9f5ef42/logs/reproducer-zuul-based-quickstart.tar

Changed in tripleo:
assignee: nobody → wes hayutin (weshayutin)
status: Triaged → Fix Released
wes hayutin (weshayutin) wrote :

[zuul@centos-7-rdo-cloud-0000000000 puppet-tripleo]$ ls
bindep.txt dist doc files Gemfile lib LICENSE manifests metadata.json Puppetfile_extras Rakefile README.md releasenotes setup.cfg setup.py spec templates tox.ini zuul.d
[zuul@centos-7-rdo-cloud-0000000000 puppet-tripleo]$ git log
commit 62e47e1357f80e458f9910efc755874383e041aa
Merge: 1128948 4b67581
Author: Openstack Triple CI <email address hidden>
Date: Tue Feb 19 21:47:32 2019 +0000

    Merge commit 'refs/changes/35/624335/15' of ssh://review.openstack.org:29418/openstack/puppet-tripleo into HEAD

commit 1128948fee0b0f9e1be306cee5879904eef43f29
Merge: dc3d3a9 ec97667
Author: Zuul <email address hidden>
Date: Tue Feb 19 19:53:54 2019 +0000

    Merge "Change haproxy mode to http for octavia"

commit 4b67581ec903e85f3d6188c6cf0782fd6ec0865a
Author: Lee Yarwood <email address hidden>
Date: Mon Dec 10 20:01:01 2018 +0000

    placement: Initial extraction of the Placement service from Nova

    This initial change duplicates the existing Nova Placement parameters
    and classes with extracted versions to avoid disrupting CI during the
    switch.

    Change-Id: Ieb5b6586bfcdcf4fe5aef7338ee17f7c9e55b607

commit dc3d3a92bc06297e67fc248a1b3fee73408332d5
Author: Michele Baldessari <email address hidden>

Bogdan Dobrelya (bogdando) wrote :

nice!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers