undercloud upgrade using stale t-h-t

Bug #1794770 reported by Jiří Stránský on 2018-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tripleo
Critical
Jiří Stránský

Bug Description

Now that we use t-h-t to upgrade undercloud, we need to make sure we update the t-h-t package *before* we trigger undercloud upgrade, otherwise the upgrade will run with upgrade_tasks which are outdated.

Fix proposed to branch: master
Review: https://review.openstack.org/605745

Changed in tripleo:
assignee: nobody → Jiří Stránský (jistr)
status: Triaged → In Progress
Bogdan Dobrelya (bogdando) wrote :

could we use the tht compat package for that?

Jiří Stránský (jistr) wrote :

(Replied on the review -- i don't think so.)

Reviewed: https://review.openstack.org/606900
Committed: https://git.openstack.org/cgit/openstack/tripleo-docs/commit/?id=c027c7e238b02746fae511a26c56f34879128d5e
Submitter: Zuul
Branch: master

commit c027c7e238b02746fae511a26c56f34879128d5e
Author: Jiri Stransky <email address hidden>
Date: Mon Oct 1 10:02:02 2018 +0200

    Undercloud upgrade docs -- "yum update" necessary packages

    Expand the list of packages to `yum update` prior running `undercloud
    upgrade`:

    * openstack-tripleo-common -- we use direct Python imports from common
      to tripleoclient.

    * openstack-tripleo-heat-templates -- nowadays we upgrade the
      undercloud based on t-h-t content, we need the latest content before
      we trigger the upgrade.

    Change-Id: Ie7a51bebb1d18c6f4442c5177f593008819ae51c
    Partial-Bug: #1794770

Change abandoned by Juan Antonio Osorio Robles (<email address hidden>) on branch: master
Review: https://review.openstack.org/605745
Reason: Having issues at the gate, abandoning temporarily.

Reviewed: https://review.openstack.org/605745
Committed: https://git.openstack.org/cgit/openstack/tripleo-upgrade/commit/?id=46113038c1c88bd35e11308efabd65aec3d559b2
Submitter: Zuul
Branch: master

commit 46113038c1c88bd35e11308efabd65aec3d559b2
Author: Jiri Stransky <email address hidden>
Date: Thu Sep 27 16:11:57 2018 +0200

    Update required packages for containerized undercloud upgrade

    Expand the list of packages to `yum update` prior running `undercloud
    upgrade`:

    * openstack-tripleo-common -- we use direct Python imports from common
      to tripleoclient.

    * openstack-tripleo-heat-templates -- nowadays we upgrade the
      undercloud based on t-h-t content, we need the latest content before
      we trigger the upgrade.

    Change-Id: Ic578de2237f9a43ff4fcd24141802a49a06be59c
    Partial-Bug: #1794770

Changed in tripleo:
milestone: stein-1 → stein-2
Changed in tripleo:
milestone: stein-2 → stein-3
Changed in tripleo:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers