stable/queens: No image with the name 'bm-deploy-kernel' found - make sure you have uploaded boot images."

Bug #1789416 reported by Sorin Sbarnea on 2018-08-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tripleo
Critical
wes hayutin

Bug Description

Builds are failing on stable/queens with this error:

[u"No image with the name 'bm-deploy-kernel' found - make sure you have uploaded boot images.", u"No image with the name 'bm-deploy-ramdisk' found - make sure you have uploaded boot images.", u'Not enough baremetal nodes - available: 0, requested: 1', u'Not enough baremetal nodes - available: 0, requested: 1', u'Not enough baremetal nodes - available: 0, requested: 1', u'Not enough baremetal nodes - available: 0, requested: 1', u'Not enough baremetal nodes - available: 0, requested: 1', u'Not enough baremetal nodes - available: 0, requested: 1', u'Not enough baremetal nodes - available: 0, requested: 1', u'Not enough baremetal nodes - available: 0, requested: 1', u'Not enough baremetal nodes - available: 0, requested: 1', u'Not enough baremetal nodes - available: 0, requested: 1', u'Not enough baremetal nodes - available: 0, requested: 1', u'Not enough baremetal nodes - available: 0, requested: 1', u'Not enough baremetal nodes - available: 0, requested: 1', u"No image with the name 'bm-deploy-kernel' fouConfiguration has 18 errors, fix them before proceeding. Ignoring these errors is likely to lead to a failed deploy.
2018-08-28 04:05:04 | nd - make sure you have uploaded boot images.", u"No image with the name 'bm-deploy-ramdisk' found - make sure you have uploaded boot images.", u'Not enough baremetal nodes - available: 0, requested: 1']
2018-08-28 04:05:04 | Removing the current plan files

Log: http://logs.openstack.org/57/595357/1/check/tripleo-ci-centos-7-scenario001-multinode-oooq-container/e3b5773/logs/undercloud/home/zuul/overcloud_deploy.log.txt.gz
Gate Test Change: https://review.openstack.org/#/c/567224

Sorin Sbarnea (ssbarnea) on 2018-08-28
tags: added: alert
wes hayutin (weshayutin) on 2018-08-28
Changed in tripleo:
importance: Undecided → Critical
status: New → Triaged
milestone: none → rocky-rc2
tags: added: promotion-blocker

Fix proposed to branch: master
Review: https://review.openstack.org/597141

Changed in tripleo:
assignee: nobody → wes hayutin (weshayutin)
status: Triaged → In Progress
wes hayutin (weshayutin) wrote :

OK.. using https://review.openstack.org/#/c/597142/ to test.
I have success on scen002, 003 and failing still on scen001/004

I found a successful queens jobs, scen001 from the gate logs

http://logs.openstack.org/48/588848/1/gate/tripleo-ci-centos-7-scenario001-multinode-oooq-container/75a2172/logs/undercloud/home/zuul/overcloud-deploy.sh

Here is copy of latest queens timed out job

http://logs.openstack.org/24/567224/94/check/tripleo-ci-centos-7-scenario001-multinode-oooq-container/6307c0e/logs/undercloud/home/zuul/overcloud-deploy.sh

The deployment args look the same between last known good, and the timed out version

https://www.diffchecker.com/IdsadeNK

Here is a diff from my change.
https://www.diffchecker.com/ktpVyZoz

Also testing if the removal of bootstrap subnodes is the root cause
https://review.openstack.org/#/c/597239/

Reviewed: https://review.openstack.org/597141
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart/commit/?id=b77944cf2392723310d0a0d540c43be804720f65
Submitter: Zuul
Branch: master

commit b77944cf2392723310d0a0d540c43be804720f65
Author: Wes Hayutin <email address hidden>
Date: Tue Aug 28 10:12:18 2018 -0400

    set the correct config download settings for queens

    The scenario based deployments were not updated properly
    for config download.

    Closes-Bug: #1789416
    Change-Id: I881f92e6cef4de58a9731f03669e42bc862964ec

Changed in tripleo:
status: In Progress → Fix Released

Related fix proposed to branch: master
Review: https://review.openstack.org/599088

Reviewed: https://review.openstack.org/599088
Committed: https://git.openstack.org/cgit/openstack/tripleo-quickstart/commit/?id=a0aad6e280af998b7283b465c3d83f518971d16c
Submitter: Zuul
Branch: master

commit a0aad6e280af998b7283b465c3d83f518971d16c
Author: Alex Schultz <email address hidden>
Date: Fri Aug 31 16:21:56 2018 -0600

    Fix queens fs016 fs019

    In queens, the ceph-ansible workflow does not work with config download.
    These jobs should not be using config-download. This was improperly
    converted as part of I881f92e6cef4de58a9731f03669e42bc862964ec. This is
    a partial revert of that patch for featureset016 and featureset019. The
    featureset documentation indicates that these are not configured with
    config download.

    https://docs.openstack.org/tripleo-quickstart/latest/feature-configuration.html

    Change-Id: Ib6c3ca7886c5e4adb0883c501bfbb390e15d108f
    Closes-Bug: #1790144
    Related-Bug: #1789416

Changed in tripleo:
milestone: rocky-rc2 → stein-1

Change abandoned by Jose Luis Franco (<email address hidden>) on branch: master
Review: https://review.openstack.org/597450

This issue was fixed in the openstack/tripleo-quickstart 2.1.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers